php.ini parameters options are not taken in account

Discussion in 'General' started by philippeS, Mar 13, 2015.

  1. philippeS

    philippeS New Member


    under Websites, when I put for example this php.ini parameters in the options tab :
    post_max_size = 20M
    upload_max_filesize = 20M
    a php.ini file is well created in the folder /var/www/conf/webX
    at the end at the file I find the 2 snippets below, but in phpinfo() the parameters remain the default ones 8Mo and 2Mo.
    any idea,

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    which php mode do you use for that website in ispconfig and whcih php handler is displayed in phpinfo output?
  3. philippeS

    philippeS New Member

    I use Mod-PHP and sorry for the php handler, I'm not sure what you need.... What I see in phpinfo() is that the php.ini file loaded is the one in /etc/php5/apache2 directory. I have this line commented in the vhost file of the website in apache2 config :
    137 # PHPIniDir /var/www/conf/web2
    this line should be uncommented by ISPConfig isn't it ?


  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to switch to php-fcgi or php-fpm. mod_php should not be used anymore as it runs php under the wrong user so it is insecure and not suited to run cms or shop systems that have to write files to disk and it does not support custom php.ini files.
    This has to be commented out, so please add the # in front again and change the php mode. By removing the #, you tell the server to use the directory /var/www/conf/web2 for all new websites tha you will add in future, not just for this website.
  5. philippeS

    philippeS New Member

    Ok I did what you tell
    put the # in the vhost apache2 config file of the website
    and set php-fpm for this website but seems not enough to do
    # apt-get install libapache2-mod-fastcgi php5-fpm
    php5-fpm service is running ok
    # a2enmod actions fastcgi alias
    # service apache2 restart
    no sign of php-fpm in phpinfo()
    anything more to do in ISPConfig directly to make things working ? Do I have to register Additional PHP version ? (php5-fpm is the same version : 5.5.9)


  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If you installed your server as describe din the perfect setup guides, then php-fpm should work out of the box. If you installed php-fpm later after you installed ispconfig, then it might be that some config is missing.

    Did you try to use php-fcgi?
  7. philippeS

    philippeS New Member

    ok it works with fastcgi, so I will make working php-fpm on my next perfect setup install :)
    thanks a lot Till !

Share This Page