php.ini - need to find right one

Discussion in 'General' started by smokinjo, Aug 15, 2016.

  1. smokinjo

    smokinjo Member

    Hello,
    I have installed suitecrm, a crm software based on sugarcrm.


    It has a 7 or 8MB upload memory limit on files. I need to up this, because I need to upgrade SuiteCRM' and the upgrade file is 0.5MB too big. I want to increase the size.
    It turns out that I need to modify the php.ini file

    I ran the locate command and found a few of them:
    /etc/php5/apache2/php.ini
    /etc/php5/cgi/php.ini
    /etc/php5/cli/php.ini
    /root/oldweb/web/opencart/php.ini
    /root/oldweb/web/opencart/admin/php.ini
    /root/web/opencart/php.ini
    /root/web/opencart/admin/php.ini
    /usr/share/php5/php.ini-development
    /usr/share/php5/php.ini-production
    /usr/share/php5/php.ini-production.cli
    /var/www/clients/client2/web3/web/humogene/admin/php.ini

    I modified the first one of the list. But, this has no affect.
    Can some one point me to the correct php.ini file to change?

    Thanks
    Joseph
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you use php mode php-fcgi, then it is this one: /etc/php5/cgi/php.ini

    If you want to edit the limit for this one site only, use the custom php.ini field of the website.
     
  3. smokinjo

    smokinjo Member

    Hello Till,

    Thanks!
    how does one tel which phop mode one is using?
    If it helps, I modified nothing that pertains to php options. I used the php that is running under a fresh install.
    I will inquire about the local pho.inidile in suitecrm too.

    Thanks

    Joseph
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You see it in the website settings of the website in ISPConfig.
     
  5. smokinjo

    smokinjo Member

    It turns out that it is set up for Fast-CGI.
    Does that I mean I need to modify:
    /etc/php5/cgi/php.ini

    Thanks
    Joseph
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, or use the custom php.ini field. And then restart apache.
     
  7. smokinjo

    smokinjo Member

    Hello,
    I was able to take the time today to apply the new idea of modifying the pho.ini file:
    /etc/php5/cgi/php.ini

    I restarted the server for the change to take effect.

    It fails, says that I am short my 200k.

    The files suggested did not seem to work. I increased the limit to 25M
    I also saved, left, and reloaded the file to make sure that it saved.

    I tried the other php.ini file as well:
    /etc/php5/cli/php.ini

    Same 25M' but not working.
    I changed the apache2 ones in the beginning, and it did not work.
    According to the locate command, I have no other php.ini files related to the server (only direct ones related to specific software).

    Ideas?
    Is there a way to see in the logs which php.ini file is being consulted?

    Thanks for any ideas.

    Joseph
     
  8. Jesse Norell

    Jesse Norell Active Member

    You restarted the entire machine? (FastCGI runs separately from the web sever, so if you only restarted apache, that won't catch it.)

    Create a script to run phpinfo() and it will show you the 'Loaded Configuration File'.
     

Share This Page