php in vhost did not work

Discussion in 'Installation/Configuration' started by Elfchen, Jun 25, 2007.

  1. Elfchen

    Elfchen New Member

    Dear community!

    I have installed system on a SUSE 10.2 system and it worked very well from start. I am able to login into panel and create vhosts. I have moved from /srv/www to /home/www after installation.

    Now php did not work for vhosts and I can't find the reason, cause mod_php5 is enabled inside apache but every time it tries to open .php files as file for transfer in browser instead of showing the file content.

    I am confused now what happend. The apache error log shows:

    [Mon Jun 25 13:12:14 2007] [error] an unknown filter was not added: PHP
    [Mon Jun 25 13:12:14 2007] [error] an unknown filter was not added: PHP
    [Mon Jun 25 13:12:15 2007] [error] an unknown filter was not added: PHP
    [Mon Jun 25 13:12:15 2007] [error] an unknown filter was not added: PHP

    on access log i see:

    1.2.3.4 - - [25/Jun/2007:13:12:14 +0200] "GET /php.php HTTP/1.1" 200 17 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4"

    I've installed the latest version about 10 days ago.

    Thank you for assistance.

    Remember: Php itself works well, cause ISPConfig is based on Php and this works :)
    html works well inside the virtual hosts.
    So maybe it's some path or variable ... but didn't find it ... developer please help.
     
    Last edited: Jun 25, 2007
  2. Elfchen

    Elfchen New Member

    help

    nobody who can help me?


    ... now have run ./setup again ...

    tried other board posts:

    changed in config both to addtype

    vhost result:

    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /home/www/web11/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /home/www/web11/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode On

    /etc/apache2 # ls -la /etc/apache2/vhosts
    total 24
    drwxr-xr-x 2 root root 4096 Jun 25 22:05 .
    drwxr-xr-x 13 root root 4096 Jun 25 22:16 ..
    -rw-r--r-- 1 root root 4989 Jun 25 22:28 Vhosts_ispconfig.conf
    -rw-r--r-- 1 root root 4800 Jun 25 22:28 Vhosts_ispconfig.conf~

    25.06.2007 - 22:28:11 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 892: setquota -T -u web11_domain.tld 604800 604800 -a &> /dev/null
    25.06.2007 - 22:28:11 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 57: cp -f /root/ispconfig/isp/conf/forward.master /home/www/web11/.forward
    25.06.2007 - 22:28:11 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
    25.06.2007 - 22:28:11 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
    25.06.2007 - 22:28:12 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
    25.06.2007 - 22:28:12 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1231: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
    25.06.2007 - 22:28:13 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2418: httpd -t &> /dev/null
    25.06.2007 - 22:28:13 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2425: httpd syntax ok
    25.06.2007 - 22:28:14 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/apache2 reload &> /dev/null
    25.06.2007 - 22:28:14 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1892: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~



    no matter if using addhandler or addtype

    $go_info["server"]["postfix_config"] = 1; // 1 = SENDMAIL-STYLE, 2 = POSTFIX-STYLE
    $go_info["server"]["smtp_restart"] = 1; // 1 = stop/start, 2 = restart
    $go_info["server"]["network_config"] = 0; // 0 = none, 1 = automatic
    $go_info["server"]["sudo_du_enabled"] = 0; // enable sudo for gathering website file usage
    $go_info["server"]["apache2_php"] = 'addhandler'; // 'filter' = set PHP filters, 'addtype' = Set PHP addtype or 'both' = Set Filter + Addtype, suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)

    still did not work

    same result!

    Developer - where did you define the allowed path for php please?
     
    Last edited: Jun 25, 2007
  3. mlz

    mlz New Member

    A couple of things, realize that ISPConfig has it's own PHP, it's not the one that your websites would use (and shouldn't be, it's optimized for ISPConfig.) Have you made sure that your distributions PHP has been installed?

    BTW, I would have answered sooner, but the first thing I saw when I looked at your first post earlier was that it was a Suse problem. Now I have nothing against Suse, but I run CentOS, so I jumped back to the message list.

    Also, try to be patient, not everyone can get to every message right away, or they may need to think about it before they give an answer. For those of us in the US, it's just getting to the end of the business day, most people are at work. I love ISPConfig and try to help where I can, but even checking in during the day, I tend to skip through until after I leave the office.

    The first thing that needs to be established is if there is PHP installed. Have you tried the following? (should be distro independent)

    Code:
    # updatedb && locate libphp
    
    (Give that a little time, updatedb takes a bit to run...)
     
  4. Elfchen

    Elfchen New Member

    I found out how to fix

    I have found out how to fix.

    You told me it uses own PHP environment - but maybe not completly :)

    I have removed apache complety and removed php completly including all php extension modules.

    After that I installed this 2 sections again with the ISPConfig installer.

    After that was done PHP worked well.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am not sure what you did as the php installer can not install apache2 and php for you, but niceto see that it worked.
     
  6. Elfchen

    Elfchen New Member

    what i did was to use not a blank brand new suse. i used an server where already apache and php was installed before using ispconfig :)
     

Share This Page