PHP-FPM with socket not working

Discussion in 'ISPConfig 3 Priority Support' started by HSorgYves, Aug 16, 2017.

  1. HSorgYves

    HSorgYves Active Member

    The vhost file generated is wrong for PHP-FPM. When I select use socket under options, the FastCgiExternalServer still uses TCP.
    Any suggestions?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's a known issue, some FCGI versions do not support sockets, so ISPConfig switches to TCP in this case to prevent that the server fails.
     
  3. HSorgYves

    HSorgYves Active Member

    This was using the default php-fpm from Debian Stretch 9.1 which automatically uses sockets...
    All my php versions support sockets (5.6, 7.0, 7.1 and 7.2), how can I force to use sockets?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    you can't without changing the ispconfig source code (apache or ngnx plugin, depending on your server setup).
     
  5. HSorgYves

    HSorgYves Active Member

    So I can't force it in the config template? What check do you do to test if FCGI supports sockets (maybe I can bypass it there)?
    P.S.: I am using apache.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I just took a look in the code and the restriction to force port based connections has been removed already. I guess you don't use the latest ISPConfig version 3.1.6?
     
  7. HSorgYves

    HSorgYves Active Member

    You were right, at the time I didn't use ISPConfig 3.1.6. To avoid loss of time for both of us, I upgraded and tried to test the new setup. However it still doesn't work... PHP-FPM works fine with own compiled versions of php. However it does not work with the official Debian version, thus I guess it is a configuration problem. As the configuration is different for the default and the custom php versions, it is hard to compare... any suggestion is welcome!

    Thanks,
    Yves

    Screen Shot 2017-08-27 at 22.53.32.png
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Here are the settings of a Debian 9 perfect server setup.
     

    Attached Files:

    HSorgYves likes this.
  9. HSorgYves

    HSorgYves Active Member

    It's working now. Many thanks! Great support as always!
     

Share This Page