php-fpm with ISPConfig on apache

Discussion in 'Installation/Configuration' started by erkan, May 18, 2012.

  1. erkan

    erkan New Member

    Is it possible to use php-fpm with ISPConfig on an apache server?
     
  2. till

    till Super Moderator

    This will be possible with the next ISPConfig major release 3.0.5and is already implemented in SVN.
     
  3. erkan

    erkan New Member

    Ok nice! Do you know when 3.0.5 stable will be released? Or can I download a test version somewhere?
     
  4. till

    till Super Moderator

    3.0.5 will be released this summer when the last features on the feature list are implemented:

    http://bugtracker.ispconfig.org/index.php?do=roadmap&project=3

    You can get the development version from svn:

    Code:
    svn checkout svn://svn.ispconfig.org/ispconfig3/trunk
    Please note that svn versions contain untested code and should not be used on a production server.
     
  5. erkan

    erkan New Member

    Can I run a wget URL in order to install it? Like I do when I install IPSConfig 3.0.4.
     
  6. till

    till Super Moderator

    No, you have to use the svn command that I posted above to get the svn version.
     
  7. erkan

    erkan New Member

    But how do I install it? I tried running the command but I just get "command not found".
     
  8. till

    till Super Moderator

    run:

    apt-get install subversion

    to install it on debian or ubuntu.
     
  9. erkan

    erkan New Member

    But first I have to add the svn link in the sources file?
     
  10. till

    till Super Moderator

    No. Just run the command I posted above and then install ispconfig with the normal install.php script which is in the install subfolder.

    Please note that the svn version is for developers only as its untested code, so it can break your setup or requre additional cosing or changes in config files to get it working.
     
  11. erkan

    erkan New Member

    Yes I know, I just need to know if this setup would work for my site or if I need to look for something else.

    Ok I have now downloaded ISPConfig, what do I need to run in order to start the installation?
     
  12. till

    till Super Moderator

    Before you install ispconfig, ensure that you configured your server as described in the perfect setup guide as these are the install requirements for ispconfig. The perfects etuo guide contains also the instructions to install ispconfig, the only difference is that you downloaded it from svn and not with wget.
     
  13. erkan

    erkan New Member

    I have done that but I can´t get the installer to start.

    After downloaded I tried to run: cd ispconfig3_install/install/

    And: php -q install.php

    But nothing works.
     
  14. erkan

    erkan New Member

    I got the installation to start now! But ISPConfig says I have version 3.0.4.4, shouldn´t it say I have 3.0.5?
     
  15. erkan

    erkan New Member

    Ok I have gotten ISPonfig and PHP-FPM up and working now. I have also created a site and uploaded a website but all I get is a 500 internal server error.

    http://www.ffatest.se/

    Is it a bug or is it me that haven´t configured PHP-FPM properly?
     
  16. falko

    falko Super Moderator

    Please check your logs.
     
  17. erkan

    erkan New Member

    Last edited: May 19, 2012
  18. erkan

    erkan New Member

    It seems that I have installed mod_fcgid instead of mod_fastcgi that must be why PHP-FPM isn´t working.
     
  19. falko

    falko Super Moderator

  20. erkan

    erkan New Member

    I tried running:

    apt-get install libapache2-mod-fastcgi

    But it won´t install. It just says:

    Package libapache2-mod-fastcgi is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'libapache2-mod-fastcgi' has no installation candidate

    Do you know what the problem is?
     

Share This Page