PHP-FPM enabled websites showing source code

Discussion in 'ISPConfig 3 Priority Support' started by medo, Aug 7, 2014.

  1. medo

    medo New Member HowtoForge Supporter

    Hi all,

    In order to reduce CPU load on my servers, I wanted to change from Fastcgi to PHP-FPM in order to limit number of CGI processes being executed. (35 websites on a server)

    But when I change that parameter in a website, it instantly shows PHP source code ?

    Does anyone have an explanation ?

    ISPConfig, Wheezy

    Thank you.
    Last edited: Aug 7, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that apache mod_fastcgi (dont mix up with mod_fcgi) is installed and enabled and php-fpm must be installed as well. see php-fpm install chapter of the wheezy perfect server guide
  3. medo

    medo New Member HowtoForge Supporter

    Thanks, perfect.

    Exactly !

    Here is how I could switch to php-fpm :
    • Add non-free debian repository to apt
    • apt-get update && apt-get upgrade
    • apt-get install libapache2-mod-fastcgi
    • a2enmod fastcgi
    • service apache2 restart

    and everything went fine (php5-fpm was already installed)

    Thank you!

Share This Page