PHP-FPM doesn't work

Discussion in 'Installation/Configuration' started by kubus, May 21, 2016.

  1. kubus

    kubus New Member

    Hi all,

    I installed ubuntu web server today from this tutorial:

    And everything seems to be fine and works, but only when i set via ispconfig php-fpm for website Im getting 500 error. Other mods like Mod-PHP, HHVM, Fast-CGI works fine...

    error log:
    [Fri May 20 23:43:08.488175 2016] [autoindex:error] [pid 3166] (13)Permission denied: [client] AH01275: Can't open directory for index: /var/www/clients/client1/web1/web/
    [Fri May 20 23:43:16.282582 2016] [fastcgi:error] [pid 3167] (111)Connection refused: [client] FastCGI: failed to connect to server "/var/www/clients/client1/web1/cgi-bin/": connect() failed
    [Fri May 20 23:43:16.282710 2016] [fastcgi:error] [pid 3167] [client] FastCGI: incomplete headers (0 bytes) received from server "/var/www/clients/client1/web1/cgi-bin/"

    Is there some special settings what Im missing?

    Thanks for your help!
  2. PepinCZ

    PepinCZ New Member

    There will be problem with permissions.
    Try running chown -R web1:client1 /var/www/clients/client1/web1/ as root.

Share This Page