PHP-FPM does not parse PHP code

Discussion in 'General' started by holykim, Mar 28, 2013.

  1. holykim

    holykim Member

    I have installed ISPConfig on one of my servers as a slave refer to the following tutorial "The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3)". For use multiple PHP versions I also installed PHP-FPM with the following tutorial "How To Use Multiple PHP Versions (PHP-FPM & FastCGI) With ISPConfig 3 (CentOS 6.3)".

    Both default and additional FastCGI works perfect but PHP-FPM doesn't seem to be working as the below code shows a blank page. PHP-FPM doesn't parse PHP code with some reason but I can not figure it out. Please advise.

    <?php phpinfo(); ?>
    Thanks in advance.

  2. holykim

    holykim Member

    I have fixed this issue with the following three steps.
    Thanks Lionheart82 for your update at

    1. install mod_fastcgi ( yum install mod_fastcgi )
    2. FastCgiWrapper Off in /etc/httpd/conf.d/fastcgi.conf
    3. restart Apache.

    Hope this will be added to the tutorials.

  3. mattheoh

    mattheoh New Member


    I continue this thread 'cause I have a similar issue.
    I installed an additional PHP version followinf this tuto : How To Use Multiple PHP Versions (PHP-FPM & FastCGI) With ISPConfig 3 (Ubuntu 13.04)

    I m on a Gentoo, but the process is the same...

    I just followed the first step for PHP-FPM with PHP 5.3.24
    (I had already PHP 5.4 installed and I just wanted ti use the 5.3 for a website)

    unfortunately PHP is not parsed too...

    I installed mod_fastcgi as written below, and here's my fastcgi.conf :

    <IfModule mod_fastcgi.c>
      AddHandler fastcgi-script .fcgi
      #FastCgiWrapper /usr/lib/apache2/suexec
      FastCgiIpcDir /var/lib/apache2/fastcgi
    If someone have an idea, he's welcome ;-)
    thanks per advance

Share This Page