php-fpm custom settings saved but not loaded

Discussion in 'Installation/Configuration' started by Kojo Unsui, Jan 30, 2015.

  1. Kojo Unsui

    Kojo Unsui New Member

    I installed ISpconfig 3.0.5 on a Ubuntu 14.04 "Trusty Tahr" LTS in october and I'm really fine with it.
    Using fast-cgi with old php 5.2 on some websites, and php-fpm with php 5.5.9 for others...
    Anyway I've got 2 pbs related to php-fpm, I'll make a post for each, for the sake of clarity...

    It appears that I can't change anymore the php settings values for any of my php-fpm sites, despite repeating all steps several times :(
    As per the manual, I wrote some settings in the custom settings form in the options tab of Ispconfig UI.
    error_reporting = E_ALL
    display_errors = On
    memory_limit = 512M
    Then I restarted apache and even more :
    service php5-fpm restart
    service apache2 reload
    /usr/local/ispconfig/server/ ...
    Now into the related file /etc/php5/fpm/pool.d/web7.conf, I can check the values were added at the bottom :
    listen = /var/lib/php5-fpm/web7.sock
    listen.owner = web7 = client2
    listen.mode = 0660
    user = web7
    group = client2
    pm = dynamic
    pm.max_children = 10
    pm.start_servers = 4
    pm.min_spare_servers = 2
    pm.max_spare_servers = 6
    pm.max_requests = 2000
    chdir = /
    php_admin_value[open_basedir] = /var/www/clients/client2/web7/web:/var/www/clients/client2/web7/private:/var/www/clients/client2/web7/tmp:/var/www/
    php_admin_value[session.save_path] = /var/www/clients/client2/web7/tmp
    php_admin_value[upload_tmp_dir] = /var/www/clients/client2/web7/tmp
    php_admin_value[sendmail_path] = "/usr/sbin/sendmail -t -i [email protected]"
    php_admin_value[error_reporting] = E_ALL
    php_admin_flag[display_errors] = On
    php_admin_value[memory_limit] = 512M
    Anyway, the phpinfo still shows me old settings, and any code typo will result in a blank page, no error displayed...
    Loaded Configuration File   /etc/php5/fpm/php.ini
    display_errors   Off
    memory_limit   128M
    Then, desperated, because I couldn't find where these settings are picked I also edited the relevant php.ini
    and even, one by one all my ini files (!) with memory_limit = 512M...
    find / -name 'php.ini'
    No way, phpinfo still returning memory_limit 128M and other old settings...
    I checked in the server for any file where the memory_limit could be set :
     grep --exclude-dir={/var/www/clients/} -rnw '/' -e 'memory_limit'
    and got a bunch of results, but few with memory_limit set to 128M , and I don't see why Apache would parse these files ( for example into /usr/local/src/php5-build/...) !

    Any help is really welcome, this doesn't sound logical, or I'm missing a very basic point ?
    Thanks for your great tutorials and the config Manual !
    Last edited: Feb 3, 2015
  2. Kojo Unsui

    Kojo Unsui New Member

    I don't like to "bump" a question, but I'm now completely blocked until I can solve that : why can't I change the php settings of my php-fpm configuration ?

    I would be very grateful for your help. Thank you
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if your php-fpm daemn hangs. try to restart it manually. if this wont help, then restart the server once.
  4. Kojo Unsui

    Kojo Unsui New Member

    Thanks for your reply. What do you mean by "restart php-fpm daemon manually" please ?
    I mean else than service php5-fpm restart
    Last edited: Feb 19, 2015
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have custom php-fpm versions, then each version has its own dameon. If you restarted all of them and it did not help, then restart the server.

Share This Page