php-fpm crashing when deleting multiple sites at once

Discussion in 'General' started by bundfeg, Nov 19, 2018.

  1. bundfeg

    bundfeg New Member HowtoForge Supporter

    Hi there,
    I noticed that sometimes php-7.0-fpm crashes, when I delete some sites at once. It just happened again and here are the logs from that moment:
    Code:
    [19-Nov-2018 15:42:03] NOTICE: Reloading in progress ...
    [19-Nov-2018 15:42:03] NOTICE: reloading: execvp("/usr/sbin/php-fpm7.0", {"/usr/sbin/php-fpm7.0", "--nodaemonize", "--fpm-config", "/etc/php/7.0/fpm/php-fpm.conf"})
    [19-Nov-2018 15:42:04] ERROR: failed to open configuration file '/etc/php/7.0/fpm/pool.d/web1700.conf': No such file or directory (2)
    [19-Nov-2018 15:42:04] ERROR: Unable to include /etc/php/7.0/fpm/pool.d/web1700.conf from /etc/php/7.0/fpm/php-fpm.conf at line 30
    [19-Nov-2018 15:42:04] ERROR: failed to load configuration file '/etc/php/7.0/fpm/php-fpm.conf'
    [19-Nov-2018 15:42:04] ERROR: FPM initialization failed
    
    In the sys_datalog-table I see that I deleted domain_id:1515 at timestamp 1542638475 and domain_id:1700 at 1542638484
    Seems as if the web1700.conf was already deleted when the reload from web1515 took place?
    Perhaps it is necessary to wait with deletion of pool.d/xxx.conf until php-fpm.conf is written. But thats not my field of expertise :) do you need any other data from me to get into it?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I've added it to the bug tracker so we can check that. Might be that systemd returns back to shell prompt without waiting until php-fpm process is reloaded.
     

Share This Page