PHP extensions in ISPConfig

Discussion in 'Installation/Configuration' started by johnwilson1969, Jun 26, 2007.

  1. johnwilson1969

    johnwilson1969 New Member

    I am running ISPConfig 2.2.14 which according to my phpinfo() output it is running PHP 5.2.2 but with NO extensions.

    The customer side of my web is running PHP 5.1.2 with extensions such as GD.

    I have installed the squirrelmail package from the ispconfig homepage and it installs under the ISPConfig webspace which of course uses the php version with no extensions.

    My Problem:

    I want to use some squirrelmail extensions that use the GD extensions.

    Can I recompile the php for the ispconfig (and how) or add them from somewhere (i tried adding the path to the existing extensions, but when it tried to load the extension it produced an error).

    Thanks for any help!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to recompile the ISPConfig PHP if you want to use it with GD. For the compile options, have a look at the script compile_aps/compile inside the ISPConfig installer tar.gz file.
  3. johnwilson1969

    johnwilson1969 New Member


    Thanks Till!

    I played around with the installation on my backup server today.

    (I am running ubuntu 6.06 -- not that it matters)

    I removed the /root/ispconfig directory

    untarred my original install tar

    modified the compile file

    and ran setup

    everything compiled... but it rewrote my database of websites and users. the data is still there of course. I am assuming i wiped the database when i deleted the /root/ispconfig directory.

    Will restore from a backup and try again tomorrow by just doing a reinstall over my current data. should this work????? I am assuming this would be treated as an upgrade by the installer.

    Thank you

    BTW - Love ISPConfig, thanks for all the hard work.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have a backup of the mysql database? The database is not in /root/ispconfig, it is in /var/lib/mysql/... The ISPConfig installer was not able to detect the old installation as you removed the /root/ispconfig directory which resulted in a deletion of the database by the ISPConfig installer.
  5. johnwilson1969

    johnwilson1969 New Member

    It Worked

    Finally got back around to this.

    restored from a backup

    untarred the install file, modified the php section of the compile script by adding the following option.


    ran the install, kept all my existing data.

    ran phpinfo test file, GD extension enabled.

    Thanks Till for your help!.

Share This Page