PHP Execution problems

Discussion in 'General' started by alexillsley, Dec 29, 2006.

  1. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Hello,
    :( Unfortunatley again i have got more php problems, only simple php scripts appear to excute:( for some strange reason. Look at this:

    URL: http://alexserver.redirectme.net/test2.php
    SOURCE:
    PHP:
    <html>

    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
    <title>Test Page</title>
    </head>
    <body>

    <?php
    echo 'hello';
    ?>

    </body>

    </html>

    More complex php script:

    URL: http://alexserver.redirectme.net/test.php
    SOURCE:
    PHP:
    <html>

    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
    <title>Test Page</title>
    </head>
    <body>

    <?php
    echo '<a href="?page=test">test</a>    <a href="?page=test2">test2</a>';
    if (
    $_GET['page'] == "test") { echo "test!; }
    elseif (
    $_GET['page'] == "test2") { echo "test 2!" }
    ?>

    </body>

    </html>
    On the second script it just gives a blank page not even an error message,
    Hopfully you guys can help me fix this again,
    Thanks,
    Alex
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check you php.ini file to make sure that that displying of errors is enabled. Also have a look at the apache error log file in the log directory of the website.
     
  3. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Thanks i just changed to display_errors = on in the php.ini file, thanks again
     
    Last edited: Dec 29, 2006

Share This Page