PHP errors from ISPC3 + Centos 6

Discussion in 'Installation/Configuration' started by kephra, Oct 13, 2011.

  1. kephra

    kephra Member

    I configged a Centos 6 Perfect Server with ISPC3 a few weeks ago. Mostly it has worked fine, but I notice that it is throwing lots of php errors in my httpd/error_log file. Every action I do in ISPC3 creates several php errors.

    Undefined variable: html_server in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 237,

    Undefined index: unknown in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 255,

    Undefined index: on_after_update in /usr/local/ispconfig/interface/lib/classes/ on line 140,

    Undefined variable: conf in /usr/local/ispconfig/interface/web/client/client_edit.php on line 217,

    Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 499

    Undefined index: domain in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 555

    Did I miss something in the configuration? The only change I made to the standard install was that I added postgrey to the email stack.

    Kephra aka Bill
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    These are php debug messages and not errors. You see them because the error level in the php.ini file is set too low. Edit the php.ini and set:

    error_reporting = E_ALL & ~E_NOTICE

    and then restart apache.
  3. kephra

    kephra Member

    That worked great. My error_log has quit growing.

Share This Page