php disabled on sites

Discussion in 'Installation/Configuration' started by amgat, Aug 30, 2007.

  1. amgat

    amgat New Member

    OS : Ubuntu Server 7.04

    I've had some sites created by ISPconfig running perfectly for some time.

    This morning i created a new ISPConfig site, and discovered that PHP no longer is enabled on any of my sites. Tried disable and re enable PHP for the sites but still not activated.

    I took a look at the "Vhosts_ispconfig.conf" file and discovered that the following line was missing:
    AddType application/x-httpd-php .php .php3 .php4 .php5
    If i add this line and restart apache, it works again. But as soon as i do any changes to my site in ISPConfig, PHP becomes disabled and the line is missing from vhosts_ispconfig.conf file again.

    This problem is getting on my nerves as this is a production server :) Hope someone is able to help me with this problem.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What is the value of the variable $go_info["server"]["apache2_php"] in the file /home/admispconfig/ispconfig/lib/ ?
  3. amgat

    amgat New Member

    This was changed to addtype earlier, but changed it back to "both". still no change
  4. amgat

    amgat New Member

    ah! i found out what was causing the problem. For some reason, I had commented out the line $go_info["server"]["apache2_php"] because i read in a forum somewhere that this was causing PHP log errors.

    I removed the comment and set type to "suphp". Works like a charm now. Thankyou for helping me out.

Share This Page