Php Curl update problem

Discussion in 'Installation/Configuration' started by Oitsuki, Oct 29, 2019.

  1. Oitsuki

    Oitsuki Member

    I do not know what's happen,
    I update my website for http/2 and for fast cgi and fpm, roundube do not work.
    Also, I do not know if there is a consequence but php curl do not want to install.
    Code:
    apt-get install php7.3-curl
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances      
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation :
    
    Les paquets suivants contiennent des dépendances non satisfaites :
     php7.3-curl : Dépend: libcurl3 (>= 7.44.0) mais il n'est pas installable
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
    I come back on Rouncube:
    Whe I make this https://www.mywebsite.com/webmail
    I have this message (it's summary but I can see all the file with the code).
    Not good.

    Thank you for your help for these 2 questions.

    Code:
    <?php
    /**
     +-------------------------------------------------------------------------+
     | Roundcube Webmail IMAP Client                                           |
     | Version 1.3.8                                                           |
     |                                                                         |
     | Copyright (C) 2005-2018, The Roundcube Dev Team                         |
     |                                                                         |
     | This program is free software: you can redistribute it and/or modify    |
     ........
    // include environment
    require_once 'program/include/iniset.php';
    
    // init application, start session, init output class, etc.
    $RCMAIL = rcmail::get_instance(0, $GLOBALS['env']);
    
    // Make the whole PHP output non-cacheable (#1487797)
    $RCMAIL->output->nocacheing_headers();
    $RCMAIL->output->common_headers();
    
    // turn on output buffering
    ob_start();
    
    // check if config files had errors
    if ($err_str = $RCMAIL->config->get_error()) {
        rcmail::raise_error(array(
            'code' => 601,
            'type' => 'php',
            'message' => $err_str), false, true);
    }
    
    // check DB connections and exit on failure
    if ($err_str = $RCMAIL->db->is_error()) {
        rcmail::raise_error(array(
            'code' => 603,
            'type' => 'db',
            'message' => $err_str), false, true);
    }
    ......
     
  2. Oitsuki

    Oitsuki Member

    latest ispconfig and debian 10
    Also I have noted the same problem for phpmyadmin.
    Look this post : https://www.howtoforge.com/communit...d-roundcube-displays-code-not-web-page.81265/
    I try this :
    Code:
    a2enconf roundcube
    result :
    Code:
    a2enconf roundcube
    ERROR: Conf roundcube not properly enabled: /etc/apache2/conf-enabled/roundcube.conf is a real file, not touching it
    
    a2enconf phpmyadmin
    Conf phpmyadmin already enabled
    
    This is a big problem if phpmyadmin page can not be displayed
    All the website works fine.
    Thank you for your help
     
  3. Steini86

    Steini86 Active Member

    Debian 10 has php7.3 as default, you should install php-curl instead of explicit php7.3-curl. "Should" work, if you have not messed up with additional repositories. For php would make sense to activate sury.org repo though,..

    For roundcube/phpmyadmin and php-fpm, read this thread:
    https://www.howtoforge.com/communit...be-enigma-munin-phpmyadmin-aliases-fix.77489/

    If you do not have proxy module enabled, try:
    Code:
    a2enmod proxy
    a2enmod proxy_fcgi
    (systemctl restart apache2)
    a2dismod mpm_prefork //again disable it
    a2enmod mpm_event
    systemctl restart apache2
     
    Last edited: Oct 29, 2019
  4. Oitsuki

    Oitsuki Member

    my source list is :
    Code:
    deb http://debian.mirrors.ovh.net/debian buster main
    deb-src http://debian.mirrors.ovh.net/debian buster main
    
    deb http://security.debian.org/debian-security buster/updates main
    deb-src http://security.debian.org/debian-security buster/updates main
    
    # buster-updates, previously known as 'volatile'
    deb http://debian.mirrors.ovh.net/debian buster-updates main
    deb-src http://debian.mirrors.ovh.net/debian buster-updates main
    
    Code:
    php7.3-curl:
      Installé : (aucun)
      Candidat : 7.3.11-1+0~20191026.48+debian9~1.gbpf71ca0
     Table de version :
         7.3.11-1+0~20191026.48+debian9~1.gbpf71ca0 500
            500 https://packages.sury.org/php stretch/main amd64 Packages
         7.3.11-1~deb10u1 500
            500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
         7.3.4-2 500
            500 http://debian.mirrors.ovh.net/debian buster/main amd64 Packages
            100 /var/lib/dpkg/status
    
     
    Last edited: Oct 30, 2019
  5. Oitsuki

    Oitsuki Member

    I try with aptiture
    Code:
    aptitude install php7.3-curl
    Les NOUVEAUX paquets suivants vont être installés :     
      php7.3-curl{b}
    0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 1 non mis à jour.
    Il est nécessaire de télécharger 29,0 ko d'archives. Après dépaquetage, 123 ko seront utilisés.
    Les paquets suivants ont des dépendances non satisfaites :
     php7.3-curl : Dépend: libcurl3 (>= 7.44.0) which is a virtual package and is not provided by any available package
    
    Les actions suivantes permettront de résoudre ces dépendances :
    
         Conserver les paquets suivants dans leur version actuelle :
    1)     php7.3-curl [Non installé]                               
    
    
    
    Accepter cette solution ? [Y/n/q/?] Y
    Aucun paquet ne va être installé, mis à jour ou enlevé.
    0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
    Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
     
  6. Steini86

    Steini86 Active Member

    Obviously, you have more sources installed (probably in sources.list.d folder). At least, there are the sury packages (good idea for php), but for stretch distribution, not buster.
     
  7. Oitsuki

    Oitsuki Member

    the element

    Code:
    cd /etc/apt/sources.list.d# ls
    ovhkernel.list   php.list
    
    nano ovhkernel.list
    # This repository contains OVH kernels as Debian package.
    # These can be installed along the distribution's default kernel,
    # in which case you have to choose which kernel to boot either by
    # setting GRUB_DEFAULT in /etc/default/grub, or by using the
    # 'grub-reboot' command.
    deb https://last-public-ovh-kernel.snap.mirrors.ovh.net/debian/ ovhkernel main
    
    nano php.list
    deb https://packages.sury.org/php/ stretch main
     
  8. Steini86

    Steini86 Active Member

    Congratulations, you have found the error. Hope everything is working now!
     
  9. Oitsuki

    Oitsuki Member

    no
    Code:
    nano php.list
    #deb https://packages.sury.org/php/ stretch main
    
     apt-get update
    Réception de :1 http://debian.mirrors.ovh.net/debian buster InRelease [122 kB]
    Atteint :2 http://security.debian.org/debian-security buster/updates InRelease
    Réception de :3 https://last-public-ovh-kernel.snap.mirrors.ovh.net/debian ovhkernel InRelease [4 930 B]
    Réception de :4 http://debian.mirrors.ovh.net/debian buster-updates InRelease [49,3 kB]
    176 ko réceptionnés en 1s (212 ko/s)
    Lecture des listes de paquets... Fait
    
    apt-get install php7.3-curl
    apt-get install php7.3-curl
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation :
    
    Les paquets suivants contiennent des dépendances non satisfaites :
     php7.3-curl : Dépend: php7.3-common (= 7.3.11-1~deb10u1) mais 7.3.11-1+0~20191026.48+debian9~1.gbpf71ca0 devra être installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état »
     
  10. Steini86

    Steini86 Active Member

    Uncomment line in php.list and change "stretch" to "buster". Or:
    Code:
    sh -c 'echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list'
    apt update
    apt install -f
    Seems like you have no clue about what you are doing, or how apt/debian/linux/.. works ... Please do not learn everything by try and error, start reading some documentation.
    https://www.debian.org/doc/ if for free, but there are also tons of very good books available in every language ( debian-handbook.info )
     
  11. Oitsuki

    Oitsuki Member

    Tk.
    the result last line @Steini86

    I set my website on php fast cgi for the moment

    now I have new error, it's after the installation
    PHP Notice: Error creating resource: [message] fopen(): SSL operation failed with code 1. OpenSSL Error messages:
    error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed
    [file] ......../vendor/guzzlehttp/guzzle/src/Handler/StreamHandler.php


    I must do to activate fpm ?
    Code:
    a2enmod proxy_fcgi setenvif
    a2enconf php7.3-fpm

    Code:
    Paramétrage de php7.3-fpm (7.3.11-1+0~20191026.48+debian10~1.gbpf71ca0) ...
    NOTICE: Not enabling PHP 7.3 FPM by default.
    NOTICE: To enable PHP 7.3 FPM in Apache2 do:
    NOTICE: a2enmod proxy_fcgi setenvif
    NOTICE: a2enconf php7.3-fpm
    NOTICE: You are seeing this message because you have apache2 package installed.
    Paramétrage de php-memcache (3.0.9~20170802.e702b5f-3+0~20190819.10+debian10~1.gbp7a3cf6) ...
    Paramétrage de php7.3 (7.3.11-1+0~20191026.48+debian10~1.gbpf71ca0) ...
    Paramétrage de php7.0-cgi (7.0.33-12+0~20191026.23+debian10~1.gbp940de0) ...
    Paramétrage de libapache2-mod-php7.0 (7.0.33-12+0~20191026.23+debian10~1.gbp940de0) ...
    libapache2-mod-php7.0: not switching MPM - disabled by maintainer
    Paramétrage de php7.0 (7.0.33-12+0~20191026.23+debian10~1.gbp940de0) ...
    Paramétrage de libapache2-mod-php7.3 (7.3.11-1+0~20191026.48+debian10~1.gbpf71ca0) ...
    libapache2-mod-php7.3: not switching MPM - disabled by maintainer
    Paramétrage de php-soap (2:7.3+70+0~20190814.17+debian10~1.gbp1e7da2) ...
    Paramétrage de libapache2-mod-php7.2 (7.2.24-1+0~20191026.31+debian10~1.gbpbbacde) ...
    apache2_switch_mpm prefork: Has been disabled manually, not changing
    libapache2-mod-php7.2: Could not switch to prefork MPM, not enabling PHP 7.2
    Paramétrage de php7.0-xsl (7.0.33-12+0~20191026.23+debian10~1.gbp940de0) ...
    Paramétrage de php-fpm (2:7.3+70+0~20190814.17+debian10~1.gbp1e7da2) ...
    Paramétrage de libapache2-mod-php (2:7.3+70+0~20190814.17+debian10~1.gbp1e7da2) ...
    Paramétrage de php-apcu (5.1.17+4.0.11-2+0~20190828.11+debian10~1.gbp013b27) ...
    Paramétrage de php-memcached (3.1.3+2.2.0-2+0~20190814.14+debian10~1.gbp5d60d1) ...
    Paramétrage de php (2:7.3+70+0~20190814.17+debian10~1.gbp1e7da2) ...
    Paramétrage de php7.2 (7.2.24-1+0~20191026.31+debian10~1.gbpbbacde) ...
    Traitement des actions différées (« triggers ») pour systemd (241-7~deb10u1) ...
    Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
    Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) ...
    [email protected]:/etc/apt/sources.list.d# ^C
    
    [email protected]:/etc/apt/sources.list.d# php --version
    PHP 7.3.11-1+0~20191026.48+debian10~1.gbpf71ca0 (cli) (built: Oct 26 2019 14:20:37) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies
        with Zend OPcache v7.3.11-1+0~20191026.48+debian10~1.gbpf71ca0, Copyright (c) 1999-2018, by Zend Technologies
    
     
  12. Steini86

    Steini86 Active Member

    You have to choose it in the ispconfig panel. You still have libapache2-mod-php packages installed, this is not compatible. You are mixin up incompatible things which will break your installation ...

    This is not enough information, but you are trying to open a SSL connection and the other side has an invalid certificate. If that other side is you, use a valid certificate (for example from letsencrypt)
     
  13. Oitsuki

    Oitsuki Member

    to make that, it installs all
    Code:
    sh -c 'echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list'
    apt update
    apt install -f
    but curl do not work because https://packages.sury.org/php/ buster main package is not compatible with Debian 10 buster.
    Yes work, but I have an error big step to have a good PHP for buster!
    Bad idea to go to http/2 !

    thread here on debian : http://forums.debian.net/viewtopic....56ab5f61ddf91983987c01da2668&p=710175#p710175
    and if I do that
    apt-get remove php7.3-common
    apt-get install php7.3-curl
    It will remove phpmyadmin and other thing, and I can make a mistake, and remove my data inside db and also I do not know wht's happen with ispconfig. In this moment I can not access to rounducbe or phpmayadmin (I see the php. i make another thead on that.)
     
  14. Steini86

    Steini86 Active Member

    The sury packages are perfectly compatible with Debian Buster.
    http/2 is a very good idea. Having a Debian server and not knowing how to administrate it is a bad idea!

    It will not remove your data nor your config files.

    I will not answer you anymore, as you have posted the same question in several places and got the same answers and you do not seem to be willing to read the documentation and actually learn about your system.
     
    Taleman likes this.

Share This Page