PHP Code showing instead of running

Discussion in 'Installation/Configuration' started by clintcan, Sep 17, 2011.

  1. clintcan

    clintcan New Member

    Hi all,

    I've installed ispconfig3 on a CentOS 6 server (I've installed ispconfig 2 in the past along with different versions of linux, with much success, and I decided to take the plunge and try version 3 out). Everything works, except for php on a site which I added.

    I've tried the different settings for php: Disabled, mod-php, fcgi, cgi, etc, it doesn't work at all, and just shows the php code, so I'm stuck.

    Could you help me out please? It would be much appreciated.

  2. falko

    falko Super Moderator ISPConfig Developer

    Which tutorial (URL) did you use?
    Any errors in your Apache error log?

    Did you check the vhosts created by ISPConfig if they have PHP in it?
  3. clintcan

    clintcan New Member

    Hi Falko,

    Thanks anyways, I solved it. Found out php 5.3 disables short tags by default (unlike 5.2).
  4. Mark_NL

    Mark_NL New Member

    Gotta love that! I hate short tags .. it's for lazy people and xml! ;)
  5. clintcan

    clintcan New Member

    ;) - It's funny though, so many php programs use short tags that disabling short tags cause all sorts of problems. :p
  6. Mark_NL

    Mark_NL New Member

    Well it's their own fault. People should keep to the rules and write pretty code imho.

Share This Page