php-cgi segfault after update

Discussion in 'Installation/Configuration' started by Blackdove, Jun 21, 2015.

  1. Blackdove

    Blackdove New Member

    I'm not sure if I can be helped, or if you'll be willing to as I'm not using any of the "perfect server" guide lines. I'm running my own custom version of ISPConfig for slackware (modified installer to recognize a slackware distro and appropriately setup distro templates).

    I have been running fine and with no problems for 5 years now, however since updating to the latest version ( I can no longer access the ISPConfig control panel. When I attempt to I get presented with a 500 page error and logs are showing:
    [Sun Jun 21 00:37:14.589030 2015] [fcgid:warn] [pid 18236] (104)Connection reset by peer: [client] mod_fcgid: error reading data from FastCGI server
    [Sun Jun 21 00:37:14.589087 2015] [core:error] [pid 18236] [client] End of script output before headers: index.php
    [Sun Jun 21 00:37:20.552426 2015] [fcgid:error] [pid 18235] mod_fcgid: process /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter(18246) exit(communication error), get signal 11

    I disabled every mod in php.ini except mysqli and same problem. I also created a basic test.php page within the ispconfig webroot with nothing but phpinfo() and the same error occurs when trying to access it.

    No other site hosted is encountering a problem (both domains and apps such as phpmyadmin and roundcube) just the control panel itself.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    any errors in the suexec.log file?
  3. Blackdove

    Blackdove New Member

    No, suexec shows it executed properly
    [2015-06-21 00:04:21]: uid: (5003/ispconfig) gid: (5004/ispconfig) cmd: .php-fcgi-starter

Share This Page