PHP Binaries - Fedora Core 5

Discussion in 'Installation/Configuration' started by jmead, Sep 26, 2006.

  1. jmead

    jmead New Member

    I have looked through the forum in search of an answer to my problem.

    Issues:
    When I was running the installer script, I got to a point where it was installing the PHP Binaries. I don’t have the error message, on hand as I closed out of the setup program.

    The error message was to do with the PHP Binaries not the correct version for the setup ISP Config

    I decided to update the machine

    Yum update

    Then

    Yum update php

    I have the latest version of PHP now, I went to try and run the setup script again to find that I cannot as the script loops over and over on the language selection option.

    I have removed the install directory which is the directory that was made when I extracted the zip achieve. Tried to run the script over still the same problem. I just realised that I haven’t tried re-run ./setup yet! When I get home ill give that ago. Anyone else got any suggestions about both my problems?
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Well ISPConfig compiles its own PHP, now matter what you run on your machine.

    So its helpfull to show the error messages, maybe some devel packages etc. are missing for compiling IPSConfigs "own" PHP5
     
  3. jmead

    jmead New Member

    Second Issue

    I cant get the error message anymore :(

    When i start the setup script again, i am stuck on the language selection screen i type "en" at the prompt and it keeps on cycling round and round on that screen.

    I am not sure what i am missing
     
  4. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Even if you completelty remove the install folder (But I wonder, it normally does that automatically).
    I guess you have no ISPConfig (old one from which you upgrade) running? If so, please remove the database (if created) the dir /root/ispconfig as well as /home/admispconfig and maybe run a
    userdel admispconfig
    an retry the installation.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Do what Ben suggested: Delete the install_ispconfig directory, the /root/ispconfig directory, and the /home/admispconfig directory, and also the ISPConfig database, if it exists. Then try a completely new installation.
     
  6. jmead

    jmead New Member

    Hey all

    I thought as much when i got both problems, originally i installed ISPConfig. The script worked fine till i got to a point where ISPConfig didnt have the PHP Binaries to continue or something(from memory not too sure what it said). So i then uninstalled the install directory, and unpacked the original install. I then started the install again, the language selection began to cycle over and over. At that point i had, had enough with the idea. So i reinstalled and found the perfect installation guide for Fedora! I followed the installation guide to the dot i had one other issue and that was when i got to the point of installing the recommended FTP program it would not let me start the service, so i installed the standard one that is in the installation disks. I hope this issue is not affecting the installation but i dont see why it would be.

    Am i going about this the wrong way is fedora a POS is there an ideal enviroment for ISPConfig to run in?? I need to sort this out by next week lol, any idea's because i dont have a clue why it is looping!
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What exactly do you enter when it asks you for the language? As far as I remember, you must enter the number in front of the language code (e.g. 1 ,2, ...) instead of the language code (de, en, ...).
     

Share This Page