PHP backward compatibility

Discussion in 'Installation/Configuration' started by rsteuer, Jan 16, 2017.

  1. rsteuer

    rsteuer New Member

    We have a client attempting to loading a website that was on an older server of ours running Debian 7 w/Apache 2.2.22, PHP 5.4.45 and MySQL 5.5.47. The site has been running flawlessly on that platform for several years. The client is now trying to upload to our new web servers running ISPConfig 3.1.1 on Jessie with Apache 2.4.10, PHP 5.6.29 and MariaDB 5.5.53. The site will not load after an export and import of the files and database.

    The logs indicate "PHP Parse error: syntax error: unexpected end of file in ....index.php" Since I am not well versed in this, could this be a compatibility issue? Since the site loaded on the old server with the same index.php file, we are wondering if it's associated with the version of PHP.

    Can PHP 5.4.45 be loaded on the web server without causing any problems? If so, can you provide a link to a tutorial?

    Regards,
    Rob
     

Share This Page