PHP backward compatibility issue

Discussion in 'Installation/Configuration' started by rsteuer, Jun 28, 2017.

  1. rsteuer

    rsteuer New Member

    We installed ISPConfig 3 on a single server that handled all roles (except mail). The server is running Deb 7 with Apache 2.2 and PHP 5.4.

    Recently, we configured 5 servers in cluster mode to handle control panel, web, database, and dns separately. The new web server is running Apache 2.4 and PHP 5.6 (or, optionally, PHP 7.0) All has been working fine and we've migrated all websites to the new server except for one site. The last site we have is throwing a PHP error when we access the site.
    The error is: "PHP Parse error: syntax error, unexpected end of file in ...index.php on line 143"

    The problem is that the file contains only 141 lines.

    Any suggestions?
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Try copying the file again? Maybe it got some binary characters/corruption in it. I assume it's working old server without error? Make sure it's not something simple like short open tags, but I think you get a different error for that. You could post the file here if you want and someone might take a brief look over it, though of course debugging php scripts is getting pretty far out of scope for these forums. :)
     
  3. rsteuer

    rsteuer New Member

    thanks for the reply. I copied the site files over several times, to no avail. I still have the single site running on the old server but need to get it retired soon.

    I appreciate the offer to take a look at the attached file, as this is not my area of expertise and the client has basically indicated it's not their problem. I changed the extension of the file from .php
     

    Attached Files:

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you consider to compile a php 5.4 as additional php version and use it just for this site?
     
  5. rsteuer

    rsteuer New Member

    I followed the install manual for Deb 8 w/php5.6, then added php 7 following your guide. All other sites that were migrated from php 5.4 work fine. Should I try to compile 5.4? Is there documentation available?

    Thank you
     
  6. rsteuer

    rsteuer New Member

    Do you have documentation available for compiling php 5.4 with Apache 2.4?
     
  7. Jesse Norell

    Jesse Norell Well-Known Member

    I don't see anything obvious in a quick browse .. there are short open tags in use there, maybe change those and see if it helps (ie. change all <? to <?php).
     

Share This Page