Php - apache - update

Discussion in 'Installation/Configuration' started by stef157, Mar 22, 2013.

  1. stef157

    stef157 Member

    Hi all,
    i'm back with an other question…

    So, this time I get something weird :

    When I upgrade PHP, apache stop working and nothing is accessible…
    I can't stop it… i've to killall apache and then restart it…

    Second thing, each Sunday on 7:00AM or 7:30AM, apache is stoping working and I've to do the same things as described here above.

    Somebody know where that could come from ?
    I've this version of php :
    • PHP 5.4.13-1~dotdeb.1

    and this is about APACHE :
    • Apache/2.2.16 (Debian) DAV/2
    • mod_fcgid/2.3.6
    • mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16)
    • mod_ssl/2.2.16
    • OpenSSL/0.9.8o

    If you need an other information… just tell me…

    thank you in advance !
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you check your logs?
     
  3. stef157

    stef157 Member

    More or less..
    The problem is that I've no idea where to look at..
    But if you have an idea in wich log I've to see, I'll do it :)

    And thank you for your answer !

    Edit1 :
    So yesterday, I've setup munin and here what I get :


    Code:
    Does not exist Service apache 
    
       Date:        Sun, 24 Mar 2013 06:41:15 +0100
       Action:      restart
       Description: process is not running
    Code:
    PID changed Service vsftpd 
    
       Date:        Sun, 24 Mar 2013 06:41:46 +0100
       Action:      alert
       Description: process PID changed to 13380
    Code:
    Execution failed Service apache 
    
       Date:        Sun, 24 Mar 2013 06:41:46 +0100
       Action:      alert
       Description: failed to start
    Code:
    Timeout Service apache 
    
       Date:        Sun, 24 Mar 2013 06:45:46 +0100
       Action:      unmonitor
       Description: service restarted 3 times within 3 cycles(s) - unmonitor
    Hope that can help :)

    Update 2:
    I've this line in the error.log :
    Code:
    [Sun Mar 24 06:41:02 2013] [notice] Graceful restart requested, doing restart
     
    Last edited: Mar 24, 2013
  4. stef157

    stef157 Member

    update 3:
    I think I found the problem…

    It's in the rotation log, i've an apache2 roload… and I don't know why… but when I relaod… nothing work after…
    But when I restart… it's OK…

    An idea from where that could be ?

    Thx
     

Share This Page