PHP and gd

Discussion in 'Installation/Configuration' started by pineapple, Mar 13, 2010.

  1. pineapple

    pineapple New Member

    Hello

    I am running two Debian boxes that I built by following the Lenny HOWTO. I am using them to develop a Joomla website. Several of the Joomla components require gd which I have installed but they all complain that gd is too old and should be upgraded. When I look at the PHP info it states "gd version: 2.0 or higher" but when I run apt-show-versions php5-gd I get: "php5-gd/lenny uptodate 5.2.6.dfsg.1-1+lenny6" and when I look this version up on the Debian site it is 5.2.11.dfsg.1-2

    Is PHP not using the uptodate version or reading the version incorrectly?

    regards and thanks.
     
  2. sjau

    sjau Local Meanie

    You can find here what packages versions come with what debian version:

    http://www.debian.org/distrib/packages

    You might want to enable backports....

    And yes, debian lenny has gd2.... even etch had it and I think sarge also.
     
  3. pineapple

    pineapple New Member

    Yes, I have confirmed that I am running a much more recent version of GD2. I am wondering why PHP does not recognise it as such in the info page nor pass the information correctly on to Joomla! so that it knows that the version is more recent than "2.0 or higher"?
     
  4. sjau

    sjau Local Meanie

    do you have the according php gd2 library installed?
     
  5. pineapple

    pineapple New Member

    I'm not sure what you mean. I didn't want to waste your time with a silly reply but I have googled "accorrding PHP GD2 library" and am none the wiser. Isn't GD2 a PHP library?
     

Share This Page