PHP and Apache2 problems after upgrade to Debian 8

Discussion in 'Installation/Configuration' started by tnn.luca, Nov 20, 2015.

  1. tnn.luca

    tnn.luca New Member HowtoForge Supporter

    Hi All,
    I recently update my server from debian 7 to debian 8. System Works fine now but there some function that crash.
    My problem now is that APS INSTALLER doesn't work. When i install any package, system returns the following error:

    20.11.2015-09:52 - WARNING - PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/' - /usr/lib/php5/20131226/ cannot open shared object file: No such file or directory in Unknown on line 0 PHP Warning: mysql_connect(): Headers and client library minor version mismatch. Headers:50544 Library:50625 in /var/www/clients/client22/web224/web/install_scripts/db-util.php on line 66

    if i Try to installa PHP5-IMAGICK the system give back this error:

    apt-get install php5-imagick
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    php5-imagick : Depends: phpapi-20100525
    Depends: php5-common (= 5.4.45-1~dotdeb+7.1) but 5.6.14+dfsg-0+deb8u1 is to be installed
    E: Unable to correct problems, you have held broken packages.

    If I correct my /etc/apt/sourcelist adding following repositorys, the installation of PHP5-IMAGICK but PHP5-INTL Stop work

    deb wheezy-php55 all
    deb-src wheezy-php55 all
    deb wheezy-php56 all
    deb-src wheezy-php56 all

    and APACHE2 stop works and give the following error:
    debian "Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/ into server: /usr/lib/apache2/modules/ undefined symbol: unixd_config"

    PLEASE help!! Anybody knows how to solve this Issue???

    Thanks a Lot !
  2. Hello,

    Can you please let me know your current php version ?

Share This Page