PHP 5.6 / Ubuntu 17.04 Zesty

Discussion in 'ISPConfig 3 Priority Support' started by jcmoinel, Oct 10, 2017.

  1. jcmoinel

    jcmoinel New Member

    Hi,
    i have an ISPServer 3.1.7p1 on ubuntu server 17.04 zesty, i would like install php 5.6 with this tutorial but it's for 16.04 and when i try, i have this problem :
    Code:
    ISP1:~# apt-get install libfcgi-dev libfcgi0ldbl libjpeg62-dbg libmcrypt-dev libssl-dev libc-client2007e libc-client2007e-dev libxml2-dev libbz2-dev libcurl4-openssl-dev libjpeg-dev libpng12-dev libfreetype6-dev libkrb5-dev libpq-dev libxml2-dev libxslt1-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libpng12-dev is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'libpng12-dev' has no installation candidate
    
    is it possible to install with the same tutorial for 17.04 ?

    Thank you very much

    JC
     
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

  3. jcmoinel

    jcmoinel New Member

    Thank you ztk.me,
    i have add the ppa and :
    Code:
    sudo add-apt-repository ppa:ondrej/apache2
    sudo add-apt-repository ppa:ondrej/php
    sudo apt-get update
    and when i paste :

    Code:
    apt-get install libfcgi-dev libfcgi0ldbl libjpeg62-dbg libmcrypt-dev libssl-dev libc-client2007e libc-client2007e-dev libxml2-dev libbz2-dev libcurl4-openssl-dev libjpeg-dev libpng12-dev libfreetype6-dev libkrb5-dev libpq-dev libxml2-dev libxslt1-dev
    error :
    Code:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libpng12-dev is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'libpng12-dev' has no installation candidate
    
    how i can intall php 5.6 on my server ?
    Idea : Is it possible to install php 5.6 with php 7 when new ispconfig install ?
    thank you !
    JC
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The ppa that you installed now should provide ready-made PHP 5.6 packages. Try to search for them e.g. with:

    apt-cache search php56

    to get the exact names.
     
  5. jcmoinel

    jcmoinel New Member

    th
    Code:
    [email protected]:/# apt-cache search php56
    php-symfony-polyfill-php56 - Symfony polyfill backporting some PHP 5.6+ features to lower PHP versions
    
    I do not know what to do with this but I am not an expert, I am here to learn, but here I do not see the procedure to follow to integrate this version of php in ispconfig, thanks for your help
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, that's not the right package. Personally, I don't sue that repo so I can't say what the exact names to search for are. you can try e.g. this instead:

    apt-cache search php | grep 5.6
     
  7. jcmoinel

    jcmoinel New Member

    Here is the result :

    Code:
    [email protected]:/# apt-cache search php | grep 5.6
    php-symfony-polyfill-php56 - Symfony polyfill backporting some PHP 5.6+ features to lower PHP versions
    libapache2-mod-php5.6 - server-side, HTML-embedded scripting language (Apache 2 module)
    php5.6-cgi - server-side, HTML-embedded scripting language (CGI binary)
    php5.6-cli - command-line interpreter for the PHP scripting language
    php5.6-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary)
    php5.6-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
    libphp5.6-embed - HTML-embedded scripting language (Embedded SAPI library)
    php5.6-dev - Files for PHP5.6 module development
    php5.6-common - documentation, examples and common module for PHP
    php5.6 - server-side, HTML-embedded scripting language (metapackage)
    php5.6-curl - CURL module for PHP
    php5.6-gd - GD module for PHP
    php5.6-imap - IMAP module for PHP
    php5.6-intl - Internationalisation module for PHP
    php5.6-ldap - LDAP module for PHP
    php5.6-mysql - MySQL module for PHP
    php5.6-pgsql - PostgreSQL module for PHP
    php5.6-pspell - pspell module for PHP
    php5.6-recode - recode module for PHP
    php5.6-snmp - SNMP module for PHP
    php5.6-sqlite3 - SQLite3 module for PHP
    php5.6-sybase - Sybase module for PHP
    php5.6-tidy - tidy module for PHP
    php5.6-opcache - Zend OpCache module for PHP
    php5.6-json - JSON module for PHP
    php5.6-bz2 - bzip2 module for PHP
    php5.6-mcrypt - libmcrypt module for PHP
    php5.6-odbc - ODBC module for PHP
    php5.6-readline - readline module for PHP
    php5.6-interbase - Interbase module for PHP
    php5.6-xmlrpc - XMLRPC-EPI module for PHP
    php5.6-enchant - Enchant module for PHP
    php5.6-gmp - GMP module for PHP
    php5.6-xsl - XSL module for PHP (dummy)
    php5.6-bcmath - Bcmath module for PHP
    php5.6-mbstring - MBSTRING module for PHP
    php5.6-soap - SOAP module for PHP
    php5.6-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    php5.6-zip - Zip module for PHP
    php5.6-dba - DBA module for PHP
    
     
  8. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    yes, just do
    Code:
    apt install php5.6 php5.6-fpm 
    and so on.
    depending on your needs configure default php for /usr/bin/php
    Code:
    update-alternatives --config php
    
     
  9. jcmoinel

    jcmoinel New Member

    thank you,
    now i have php5.6 and php7.0 in /usr/bin/, but php 5.6 is not listed in ispconfig
    i don't know what to put in ispconfig : system / additionnal php version
     
  10. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    Go to additional PHP versions, add one, give it a name and use the attached settings.
     

    Attached Files:

    till likes this.
  11. jcmoinel

    jcmoinel New Member

    oh yes ! it work !
    i have install php5.6-mysql etc... update php.ini and all is ok !
    thank you very much ! you're the best :)
    JC
    PS : why php5.6 is not an option when we install ispconfig ? :)
    thank you !!
     
    ztk.me likes this.
  12. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    it's not officially supported anymore and is deprecated, the current system howtos usually only deal with the versions delivered by that to keep it more simple.
    Everything else is additional and, I guess, not considered applicable for mainstream because of chance breaking things too easy :)

    I think 5.6 is an option using the automated installer however
     

Share This Page