php 5.6 and libssl.so.1.0.0 and libssl.so.1.1

Discussion in 'Installation/Configuration' started by Thrash Cardiom, Dec 2, 2019.

Tags:
  1. Thrash Cardiom

    Thrash Cardiom New Member

    I followed the instructions on installing php5.6 under ISPConfig (https://www.howtoforge.com/tutorial/how-to-install-php-7-on-debian/). This seemed to work well and I have a number of sites running on 5.6 and a number on 7.3. However, I am having issues with getting php 5.6 to use libssl.so.1.0.0.

    Some of my sites do various things with other sites. We have php programs on the sites that run the various interactions. On the sites running php 5.6, I am getting segfault errors.

    php-cgi[27767]: segfault at 7f0b3e5189c0 ip 00007f0b3e5189c0 sp 00007ffd53f3ba68 error 15 in libssl.so.1.1[7f0b3e511000+9000]​

    I am assuming that the php-cgi version being run is the 5.6 version but it seems to be attempting to use the wrong libssl library. I have all the links etc in place pointing at the correct places:

    -rw-r--r-- 1 root root 1000822 Oct 13 08:56 libssl.a
    lrwxrwxrwx 1 root root 13 Oct 13 08:56 libssl.so -> libssl.so.1.1
    lrwxrwxrwx 1 root root 32 Nov 29 19:00 libssl.so.1.0.0 -> /opt/openssl/lib/libssl.so.1.0.0
    -rw-r--r-- 2 root root 593696 Oct 13 08:56 libssl.so.1.1​

    Has anyone else had issues like this? If so, what was the fix?

    System is
    • Debian 10
    • ISPConfig 3.1.15
    • Apache2
    • php 7.3 and 5.6

    Thanks
     
  2. ahrasis

    ahrasis Well-Known Member

    Thrash Cardiom, Kedka and Steini86 like this.
  3. Steini86

    Steini86 Active Member

    You could try to change the link of file libssl.so to point at libssl.so.1.0.0 instead of libssl.so.1.1(?)
    If you are using the self-compiled version, then it could also be that you have compiled it with the wrong libssl version(?)
    I would suggest to use ondrej's packages for debian/ubuntu:
    https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/

    Edit:
    Hah, sorry just too late ;-)
     
    Thrash Cardiom likes this.
  4. Thrash Cardiom

    Thrash Cardiom New Member

  5. Thrash Cardiom

    Thrash Cardiom New Member

    Ok - Working on setting up another server and now I'm getting a GPG error on the Sury site:

    GPG error: https://packages.sury.org/php buster InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD474

    It worked the other day. In fact, it was working yesterday.
     
  6. Thrash Cardiom

    Thrash Cardiom New Member

    Hmmm - removing the repo and recreating works.
     
    ahrasis likes this.

Share This Page