PHP 5.3.29 as additional PHP-Version on Ubuntu 16.04

Discussion in 'Installation/Configuration' started by wwweiss, May 16, 2016.

  1. wwweiss

    wwweiss New Member HowtoForge Supporter

    Hi,
    I am trying to install PHP 5.3.29 as a second PHP-Version on Ubuntu 16.04 with ISPConfig. When I do apt-get build-dep php5 I get a Warning that I have to add some URIs to my sources.list. What are the correct URIs so I can get all the dependencies?
     
    olie Murphy likes this.
  2. timontomi

    timontomi New Member

    Hello, i have the same problem.
    Code:
    [email protected]:/usr/local/src/php5-build/php-5.6.21# apt-get build-dep php5
    Reading package lists... Done
    E: Unable to find a source package for php5
    
    Some ideas ?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You could try e.g.:

    apt-get build-dep php7.0
     
  4. timontomi

    timontomi New Member

    Even if i need php 5.xxx ?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The above command installs the libraries that are required to compile php, these are not php5 specific so it is very likely that the requirements from php 7 will work for php 5 as well.
     
  6. timontomi

    timontomi New Member

    upload_2016-5-20_9-18-30.png
    The same error. Hmmm.
     
  7. DaleHutch

    DaleHutch Member

    I need PHP 5 working as well with 16.04 LTS. Any updates on getting both PHP versions working on ISPconfig?
     
  8. Sérgio Mafra

    Sérgio Mafra New Member

    I have the same need. Anyone can help us?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

  10. gnoe

    gnoe New Member

    Had the same problem too.
    Tried to install additional PHP 5.6.11 on a Ubuntu 16.04 / PHP 7.0 and use it in my ISPConfig for some older sites.
    Followed instructions from here.

    apt-get build-dep php5 failed here too.

    Followed till's suggestion and run apt-get build-dep php7.0
    But first I edited sources.list and enabled all deb-src urls there.
    nano /etc/apt/sources.list and remove # in front of deb-src urls.

    No errors, no problems... :)
     
    Last edited: Jul 17, 2016
  11. olie Murphy

    olie Murphy New Member

    I also have the same problem like you
     
  12. gnoe

    gnoe New Member

    Have you tried to enable all deb-src urls in your sources.list file and then run apt-get build-dep php7.0 ?
     

Share This Page