Php 5.0.5 Causing Problems

Discussion in 'Server Operation' started by Median, Dec 2, 2006.

  1. Median

    Median New Member

    Hi.

    Quite some time ago I followed the Perfect Setup for Fedora Core 4 and dependencies. I also installed ISPConfig. This left me with php 4. something.

    All was fine apart from one website. It has Joomla and the DBQuery component which requires php 5.x.x to run properly.

    I did the apt-get install from the Perfect Setup and it upgraded php 4 to php5.0.5 which causes problems. (I see from searching that a number of packages suffer under this version of php).

    So...

    My plan was to upgrade again to php 5.2.0 using apt-get as it is by far the easiest method I have come across, but everytime I try and do this it just tells me that I already have the latest version.

    Can someone please help me to get php 5.2.0, preferably using apt-get.

    Thanks
     
  2. falko

    falko Super Moderator

    If there's no PHP 5.2.0 package for FC4, then you can't use apt to install it. You must then compile it from the sources.
     

Share This Page