Phantom DNS entry causing problems

Discussion in 'Installation/Configuration' started by httpDee, Nov 22, 2008.

  1. httpDee

    httpDee New Member

    I am running around 30 web sites on an ISPConfig machine. The system is also providing DNS (thorugh ISPConfig). I recently removed an old site, and ever since, each time I add a site or make a change to an existing site through ISPConfig, DNS will fail to restart.

    The first time this happened, it took me a while to figure out what was causing the problem, but eventually I noticed that named.conf still had an entry for the old site:

    zone "" {
    [INDENT]type master;
    file "";
    but that the zonefile listed ("") no longer existed.

    I deleted the entry in named.conf manually, then restarted DNS with /etc/init.d/named restart

    Everything worked fine, until the next time I added a new domain through ISPConfig. Once again DNS failed to restart. I checked named.conf and sure enough the entry for was back ...

    This has reoccurred many times now, and I have gotten used to manually editing named.conf and restarting, but I would love a way to fix this. Can anyone tell me where the entry in named.conf is coming from?

    Thanks in advance
  2. _X_

    _X_ New Member

    check Recycle Bin ... all of them!

    you can always try to search in ISPConfig SQL base for string:

    then you can backup that base, try to delete all records with that string and see if everthing works. If not you have base backup.

    Nevertheless manual changes to ISPConfig database are nor recomended.
  3. httpDee

    httpDee New Member

    Thanks for replying

    Thanks for the response _X_

    I checked the recycle bins ... no love there.

    I haven't made any manual changes to the database, although I will try that later ... at our next scheduled downtime period.

    I did however look around the database a little and found has a row hiding in the dns_isp_dns, dns_nodes table.

    Anyone have any insight on what other relationally referenced rows might need to be removed?
  4. _X_

    _X_ New Member

    well that's question for Till or Falco ...

    did you try to check, repair, optimise database from ISPConfig admin?

    after that search again for same domain in database.
  5. httpDee

    httpDee New Member

    Thanks again. No I didn't think of that, but I'll give it a try
  6. httpDee

    httpDee New Member

    I just wanted to give an update. This problem is still unresolved.

    I have now tried checking / repairing / optimising the database from the ISPConfig admin. No errors were encountered, but the sneakyolddomain is still present in rows of the dns_nodes and dns_isp_dns tables.

    Does anyone have any guidance about manually excising these entries from the database? Are there other entries that need to be removed as well? Is this really the source of the problem, or am I barking up a wrong tree?

    Thanks in advance for any insights...
  7. falko

    falko Super Moderator ISPConfig Developer

    If you want to remove it from the database, make a backup first, and then remove the records from dns_isp_dns, dns_nodes, and dns_dep.

Share This Page