Permissions problem on SuSE

Discussion in 'Installation/Configuration' started by Nielsterp, Aug 17, 2010.

  1. Nielsterp

    Nielsterp New Member

    Hi there, I have tried several times to get ISPConfig 3 to work, and finaly I got it to work 100 % on Debian Lenny.

    But when I install on SuSE 11.3, following the relevant how-to, I can not get FTP to work. When I have uploaded my site, the file permissions are wrong, pictures are not displayed, CSS does not work, also javascript files have a problem.

    I took a look in the pure-ftpd.conf, and UMASK are set to a "paranoid" value - but as far as I can see, the .conf file is not even used ? Does ISPConfig 3 call pure-ftpd with command-line parameters ? And if so, how can those parameters be modified ?

  2. Nielsterp

    Nielsterp New Member

    Solution found

    I have been doing a little digging into the installation php-script, and during installation ISPConfig 3 create a new /etc/pure-ftpd/pure-ftpd.conf. Hence all my attempts to set umask was just owerwritten.

    What I did was this: Follow the how-to up to the point where you have untared the ISP files. Then:

    vi /tmp/isp3_install/tpl/opensuse_pureftpd_conf.master

    and set Umask to whatever you like. 133:022 works fine.

    From here, just follow the guide...

    It seems that the Fedora-version have the correct Umask 133:022, while the SuSE version have the "paranoid" values - wich caused all the problem.

    Hope all you SuSE freaks can use this.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks for the info. I fixed it in SVN.
  4. Nielsterp

    Nielsterp New Member

    Thank you, Till. I still have a small problem though. Installed on debian, I can create a set of language files (danish) and edit them.

    But on SuSE I can not create new files from the control panel. I thought this was a side-effect of the FTP problem, but this problem persists.

    I know SuSE is not the recommended distro, but I have learned myself Linux on SuSE, I have succesful set up mailman and samba. So I have a strong preference for SuSE.

  5. Nielsterp

    Nielsterp New Member


    I can see that there is some general problems with permissions that are specific to SuSE 11.3.

    No matter what I do, I can not create a new set of language files from the control panel.

    But if I open a terminal and log in as root, and copy

    /usr/local/ispconfig/interface/lib/lang/en.lng to /usr/local/ispconfig/interface/lib/lang/da.lng

    - and when I log in to the control panel all my danish language files is there, ready to be translated.

    So this one is closed for now :)


Share This Page