Permission tfor a website folder & ssh/ftp access

Discussion in 'Installation/Configuration' started by Salital, Oct 10, 2011.

  1. Salital

    Salital New Member

    Hi Guys,

    1. I create a client with the username: 'salx'

    2. I create a website www,salx.mywebdomain.com

    3. I create for the salx client a ssh access shell

    4. I create for the salx client a ftp access

    about the above point 2. when I typed on the webaddress bar:

    www,salx.mywebdomain.com

    I receive (or everyone to type the same webaddress) the follow page message

    If I tried to access via ssh to the folder website (I use the account create at point 3. of above list) I have the access but appear the following message

    But I have access to the root filesystem I can see:

    I think it's too much bad:(

    If I access with a client ftp as Filezilla I access at the following folder

    /var/www/clients/client2/web4/web

    And in my ftp remote server listing directory I saw the following directories and one hidden file (- .bash_history)

    If I try to access to the 'web' directory (/var/www/clients/client2/web4/web) via ftp I receive the following message:

    :(

    MY QUESTION

    for this client I create a Jailkit ssh account maybe is this the problem?

    NOTE: I follow the same steps for other clients/website but I don't have the same problem ... the only problem that I have for the other client/website is that via ssh the user can reach every folder on the webserver
     
    Last edited: Oct 10, 2011
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the following output:

    grep web4 /etc/passwd


    and

    grep client2 /etc/group

    and

    ls -la /var/www/clients/client2/web4
     
  3. Salital

    Salital New Member

    answering to your questions

    'grep web4 /etc/passwd' output

    'grep client2 /etc/group' output

    'ls -la /var/www/clients/client2/web4' output

     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    chown web4:client2 /var/www/clients/client2/web4/web

    and try to access the folder again.

    Which ISPConfig version do you use?
     
  5. Salital

    Salital New Member

    Hi,

    I run from the root

    chown web4:client2 /var/www/clients/client2/web4/web

    AND

    1. I can successfully access to the website through www.salx.mywebsite.com :)))))

    2. I can access successfully to the folder website :))))

    BUT

    if I access via ssh to the folder website I reach the following path

    /var/www/clients/client2/stanmx.qaligo.com/web/home/salx

    I can reach also the root path / :((((

    About your last question 'Which ISPConfig version do you use?'

     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the exact version number.

    Have you changed the paths in ISPConfig under System > Server Config > Web where the sites are created? Because normally the path in /etc/passwd for users is something like /var/www/clients/client2/web4/web/ and not /var/www/clients/client2/salx.mywebsite.com/web/. The path never contains the domain name.
     
  7. Salital

    Salital New Member

    1. My ISPConfig version is the 'ISPConfig Version: 3.0.3.3'

    2. Under 'System > Server Config > Web' I saw that

     

Share This Page