Permission Denied - FPM with Apache

Discussion in 'ISPConfig 3 Priority Support' started by vmbelizario, Nov 14, 2017.

  1. vmbelizario

    vmbelizario New Member

    im working in a ISPconfig 3 Server.
    We already have a lot of working websites with no problem at all.
    But one website give me a error message and i just cant found whats happen to fix.
    All files (inside web directory) are with 755 permissions;
    All files (inside web directory) are with web103.client1 as owner;
    the FPM conf file (web103.conf):

    listen =
    listen.allowed_clients =
    user = web103
    group = client1

    Its a compiled php56 with FPM working in anothers websites.
    As a synfony framework, the index page is inside web/web/app.php and its configured in
    Apache directives (Ispconfig panel):

    <Directory /var/www/clients/client1/web103/web/web>
    Options Indexes FollowSymLinks
    AllowOverride all
    Require all granted

    DocumentRoot /var/www/clients/client1/web103/web/web
    DirectoryIndex app.php

    The application requires a includes inside web/app directory. But give me error :

    Warning: require_once(/var/www/clients/client1/web103/web/web/../app/bootstrap.php.cache): failed to open stream: Permission denied in /var/www/clients/client1/web103/web/web/app.php on line 6
    Fatal error: require_once(): Failed opening required '/var/www/clients/client1/web103/web/web/../app/bootstrap.php.cache' (include_path='.:/etc/php56zts/lib/php') in /var/www/clients/client1/web103/web/web/app.php on line 6

    What is wrong here ? Can someone help me ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does the file:


  3. vmbelizario

    vmbelizario New Member

    ls -la /var/www/clients/client1/web103/web/app/bootstrap.php.cache
    -rw-rw-r--+ 1 web103 client1 95447 Nov 13 19:29 /var/www/clients/client1/web103/web/app/bootstrap.php.cache
  4. vmbelizario

    vmbelizario New Member

    Look that the applications requires ../app/bootstrap.php.cache
    if i manually change the ../app to /var/www/clients/client1/web103/web/app
    then works.
    BUT its a lot of requires and i cant just change they all manually. SELINUX is disabled. Something is denying access the previous directory using ../app
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to change the PHP open_basedir setting on the options tab of this website to the word 'none' and try again (wait 1-2 minutes until you try it again). Save the current paths somewhere so that you can restore the old setting.
  6. vmbelizario

    vmbelizario New Member

    Same error.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use any PHP security extensions like suhosin?
  8. vmbelizario

    vmbelizario New Member

    Nothing. Compiled normal with FPM!

Share This Page