PERL scripts in Mozilla Browser

Discussion in 'Server Operation' started by Deepthi, Dec 20, 2005.

  1. Deepthi

    Deepthi New Member

    Hi

    i've given the permissions to my PERL scripts.I can run my PERL scripts on Mozilla browser but in unable to run my HTML pages... Why i donno.Evn ive saved the HTML scripts in the same folder..... /var/www/cgi-bin
    and the path is http://localhost:80/cgi-bin/login.pl is working well
    but http://localhost:80/cgi-bin/login.html is not working.
    I'm gettting the following error message.....

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Apache/2.0.46 (Red Hat) Server at 127.0.0.1 Port 80


    can you please help me in this.......
    Thank you
    Deepthi
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You cannot put HTML pages into the cgi-bin folder. They belong into the web folder. The cgi-bin folder is for .cgi and .pl scripts only!
     
  3. Deepthi

    Deepthi New Member

    PERL scripts in Mozilla brower

    Im thankful to you as you are responding to me quickly and giving me the best suggestions............Please help me out from this problem............I've placed the html files in /var/www/html and the perl files in /var/www/cgi-bin...........I'm accessing my perl files using the following address in Mozilla browser
    http://localhost:80/cgi-bin/login.pl
    but i just cant access the html pages..... can you please give me an idea how to access them? ill paste the code of both perl and html here.

    Following is the html page............
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <title>LOGIN PAGE</title>
    </head>
    <body>
    <br>
    <hr style="background-color: rgb(51, 204, 0);">
    <h2>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;
    &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;
    &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;
    &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; &nbsp;&nbsp;&nbsp;
    &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; &nbsp;&nbsp; &nbsp;&nbsp;&nbsp;
    &nbsp;&nbsp;&nbsp;<span style="font-style: italic;">&nbsp; &nbsp; </span><span
    style="color: rgb(51, 51, 255); font-style: italic;">LOGIN PAGE</span></h2>
    <h3></h3>
    <hr style="background-color: rgb(51, 255, 51);">
    <pre> <br> USER: <input type="text" name="user"
    size="10"><br>
    PASSWORD:<input type="password" name="password" size="10"><br>
    </pre>
    <pre><br><div style="text-align: center;">
    <form action="http://localhost:80/cgi-bin/login.pl" method="post"><input
    type="submit" name="SUBMIT" size="10"></form>
    </div>
    </pre>
    </body>
    </html>



    the PERL file is............
    #!/usr/bin/perl
    use CGI;
    use DBI;
    $cgi=new CGI;
    print $cgi->header();
    my $a=0;
    $user=$cgi->param("user");
    $password=$cgi->param("password");
    $dbh=DBI->connect("DBI:mysql:test:127.0.0.1","mysql","");
    $sql=$dbh->selectall_arrayref("select * from login where username='$user' and password='$password'");
    foreach $r(@$sql)
    {
    $a=$a+1;
    }
    $r=$a;
    if($a>0)
    {
    print"<html><body>";
    print"Content-type: text/html\n\n";
    print"User Accepted. Welcome <br>\n";
    print"<a href=\"http://localhost:80/login.html\">HOME</a>";
    print"</body></html>\n";
    }
    else
    {
    print"<html><body>";
    #print"Content-type: text/html\n\n";
    print"User Not Accepted.Check your USERID and PASSWORD>\n";
    print"<a href=\"http://localhost:80/index.html\">HOME</a>";
    print"</body></html>\n";
    }
    $st=$dbh->prepare("commit");
    $st->execute;
    exit;
    i can compile the code successfully...........
    Please help me in this...........
    Thank you
    Deepthi:)
     
  4. Deepthi

    Deepthi New Member

    Thank you.My problem get solved.......I've removed html files from cgi-bin and changed the path in perl code.......Finally they are working.....
    Thank you once again...
    Deepthi
     

Share This Page