Perl problem when installing awstats on CentOS 5.2

Discussion in 'Installation/Configuration' started by dealspiggy, Sep 12, 2008.

  1. dealspiggy

    dealspiggy New Member

    I got this error when trying to install the awstats rpm package:

    How to resolve this dependency problem? thanks
     
  2. till

    till Super Moderator

    Please run:

    perl -MCPAN -e shell

    and after the initial perl shell configuration run:

    install LWP::UserAgent

    to quot the perl shell, enter "q".
     
  3. dealspiggy

    dealspiggy New Member

    Here's the result of the installation of LWP:UserAgent

    Code:
    li27-127 /: perl -MCPAN -e shell
    Terminal does not support AddHistory.
    
    cpan shell -- CPAN exploration and modules installation (v1.7602)
    ReadLine support available (try 'install Bundle::CPAN')
    
    cpan> install LWP::UserAgent
    CPAN: Storable loaded ok
    Going to read /root/.cpan/Metadata
      Database was generated on Fri, 12 Sep 2008 12:02:48 GMT
    [B]LWP::UserAgent is up to date.[/B]
    
    
    however, when I ran 'rpm -ivh awstats-6.8-1.noarch.rpm', I still get the same error:

    I even tried restarting the server, but problem still persists.
    any ideas?

    thanks!
     
  4. till

    till Super Moderator

    I guess that the awstats rpm is not able to recognize that LWP::UserAgent is already installed. You should try to search with yum if there is a rpm package for LWP::UserAgent and install that too.
     
  5. PMan

    PMan New Member


    Did you ever figure out what was going on here? Any help appreciated.

    I'm seeing the exact same problem on Red Hat 5.2.


    [gg@ffff download]$ sudo cpan -i LWP::UserAgent
    CPAN: Storable loaded ok
    Going to read /home/jq/.cpan/Metadata
    Database was generated on Tue, 23 Sep 2008 13:28:42 GMT
    LWP::UserAgent is up to date.
    [gg@ffff download]$ sudo rpm -i awstats-6.8-1.noarch.rpm
    error: Failed dependencies:
    perl(LWP::UserAgent) is needed by awstats-6.8-1.noarch
    [gg@ffff download]$


    I can't see what the problem is and do not really want to start installing Perl modules from yum (is that even possible - I can't seem to find LWP::UserAgent using yum?)
     
  6. falko

    falko Super Moderator

    I think you can do it like this:
    Code:
    yum install perl-LWP-UserAgent
     
  7. PMan

    PMan New Member

    Thanks Falko but I don't think that package is available through yum.

    [aa@bb]$ sudo yum install perl-LWP-UserAgent
    Loading "rhnplugin" plugin
    rhel-x86_64-server-5 100% |=========================| 1.4 kB 00:00
    Setting up Install Process
    Parsing package install arguments
    No package perl-LWP-UserAgent available.
    Nothing to do
    [aa@bb]$
     
  8. falko

    falko Super Moderator

    What's the output of
    Code:
    yum search LWP
    ?
     
  9. PMan

    PMan New Member

    [aa@bb]$ sudo yum search LWP
    Loading "rhnplugin" plugin
    rhel-x86_64-server-5 100% |=========================| 1.4 kB 00:00
    perl-Crypt-SSLeay.x86_64 : Crypt::SSLeay - OpenSSL glue that provides LWP https support

    [aa@bb]$



    Looking that that I think it may be something to do with the arch. I'll have a look.
     
  10. falko

    falko Super Moderator

    Can you try this...
    Code:
    wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm
    rpm -Uvh rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm
    
    rm -f rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm
    ... and search for LWP again?
     
  11. mannes

    mannes New Member

    I've got it fixed!!!

    I searched for the missing dependencies on rpm.pbone.net You'll need the following packages:

    perl-Test-Mock-LWP-0.05-1.el5.rf.noarch.rpm
    perl-Test-MockObject-1.08-2.el5.noarch.rpm
    perl-UNIVERSAL-can-1.12-1.el5.rf.noarch.rpm
    perl-UNIVERSAL-isa-0.06-4.el5.noarch.rpm

    My distro is RHEL5.2 After installing those packages, the installation of awstats (also taken from the same site) went flawless.

    mannes

    PS: I also run the perl CPAN part.
     
  12. emostoyanov

    emostoyanov New Member

    You have to install perl-libwww-perl.noarch

    # yum install perl-libwww-perl.noarch

    This is your answer. Good luck!
     

Share This Page