perfect_setup_ubuntu_6.06

Discussion in 'HOWTO-Related Questions' started by boricua, Jun 20, 2006.

  1. boricua

    boricua New Member

    so far i ran into 2 issues would like to solvee [BTW thank you and good job on tutorial]

    issue 1.
    mysqladmin -h lares.despiertapr.com -u root password yourrootsqlpassword
    i get error: 'Host 'lares.despiertapr.com' is not allowed to connect to this MySQL server'

    issue 2 .

    apt-get install postfix postfix-tls libsasl2 sasl2-bin libsasl2-modules libdb3-util procmail
    i get ...


    [email protected]:/etc/rc2.d$ sudo apt-get install postfix postfix-tls libsasl2 sasl2-bin libsasl2-modules libdb3-util procmail
    Reading package lists... Done
    Building dependency tree... Done
    Package postfix-tls is a virtual package provided by:
    postfix 2.2.10-1ubuntu0.1
    You should explicitly select one to install.
    E: Package postfix-tls has no installation candidate


    TIA
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    mysql -u root -p
    USE mysql;
    SELECT * FROM user;
    quit;
    What's the output of the SELECT statement? And what's the output of
    Code:
    netstat -tap
    ?

    Please remove postfix-tls from the apt-get install line. TLS is included in the postfix package. It seems this has changed since I wrote the tutorial...
     
  3. boricua

    boricua New Member

    feedback

    mysql> select user, host, password from user;
    +------------------+-----------+------------------+
    | user | host | password |
    +------------------+-----------+------------------+
    | root | localhost | 062799e829100406 |
    | root | lares | |
    | debian-sys-maint | localhost | 3c1f43a36ace7666 |



    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN -
    tcp 0 0 *:netbios-ssn *:* LISTEN -
    tcp 0 0 *:sunrpc *:* LISTEN -
    tcp 0 0 lares.despiertap:domain *:* LISTEN -
    tcp 0 0 localhost:domain *:* LISTEN -
    tcp 0 0 localhost:49718 *:* LISTEN -
    tcp 0 0 localhost:ipp *:* LISTEN -
    tcp 0 0 lares.despiertapr.c:ipp *:* LISTEN -
    tcp 0 0 localhost:953 *:* LISTEN -
    tcp 0 0 *:603 *:* LISTEN -
    tcp 0 0 *:microsoft-ds *:* LISTEN -
    tcp 0 0 localhost:48351 *:* LISTEN -
    tcp 0 0 lares.despiertapr.c:ipp 192.168.1.105:49255 ESTABLISHED-
    tcp 0 0 localhost:55868 localhost:49718 ESTABLISHED-
    tcp 0 0 localhost:49718 localhost:55868 ESTABLISHED-
    tcp6 0 0 *:ssh *:* LISTEN -
    tcp6 0 0 ip6-localhost:953 *:* LISTEN -
    tcp6 0 0 lares.despiertapr.c:ssh ::ffff:192.168.1.:45746 ESTABLISHED-
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Then try
    Code:
    mysqladmin -h lares -u root password yourrootsqlpassword
    or change lares to lares.despiertapr.com in the host column of the second row in the user table.
     
  5. boricua

    boricua New Member

    neither worked

    i tried both options neither worked

    mysql> select user, host from user;
    +------------------+-----------------------+
    | user | host |
    +------------------+-----------------------+
    | root | lares.despiertapr.com |
    | debian-sys-maint | localhost |
    | root | localhost |
    +------------------+-----------------------+


    [email protected]:~$ sudo mysqladmin -h lares.despiertapr.com -u root password yourrootsqlpassword
    mysqladmin: connect to server at 'lares.despiertapr.com' failed
    error: 'Host 'lares.despiertapr.com' is not allowed to connect to this MySQL server'
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/hosts?
     
  7. boricua

    boricua New Member


    [email protected]:/etc/cron.d$ cat /etc/hosts
    127.0.0.1 localhost localdomain
    #127.0.1.1 lares.hvc.rr.com lares
    192.168.1.104 lares.despiertapr.com lares
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
     
  8. falko

    falko Super Moderator ISPConfig Developer

    That's ok. Please restart MySQL and try again.
     
  9. boricua

    boricua New Member

    mmmm

    stop/restart did the trick

    shame on me for not trying that :-(

    THANKS,

    BTW is this a typo

    echo 'pwcheck_method: saslauthd' >> /etc/postfix/sasl/smtpd.conf

    is this file already exist? in my instalation it does not exist
    [email protected]:/etc/init.d$ sudo echo 'pwcheck_method: saslauthd' >> /etc/postfix/sasl/smtpd.conf
    -bash: /etc/postfix/sasl/smtpd.conf: Permission denied
    [email protected]:/etc/init.d$ ls /etc/postfix/sasl/*
    ls: /etc/postfix/sasl/*: No such file or directory
    [email protected]:/etc/init.d$ ls /etc/postfix/sasl/
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Then you didn't follow the tutorial close enough. Please do the Postfix part of the tutorial again.
     
  11. boricua

    boricua New Member

    ok continue

    your right i had skip a part.

    now i continue with
    # 12 Courier-IMAP/Courier-POP3

    and i got this
    ubject= /C=US/ST=NY/L=New York/O=Courier Mail Server/OU=Automatically-generated IMAP SSL [email protected]
    notBefore=Jun 25 15:42:50 2006 GMT
    notAfter=Jun 25 15:42:50 2007 GMT
    SHA1 Fingerprint=3B:2A:53:EA:32:B8:C8:FC:E4:6D:04:B8:31:6F:38:10:90:00:B5:CE
    * Starting Courier IMAP-SSL server... [ ok ]

    Errors were encountered while processing:
    courier-pop-ssl
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    is it ok to proceed or something real wrong happend ?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    I'd go on. I don't know if POP3s will work then, but normally you don't need it as most people use POP3, not POP3s.
     

Share This Page