Perfect Ubuntu Server 10.04 - Delete First Site Created

Discussion in 'Installation/Configuration' started by mintydave, Dec 10, 2011.

  1. mintydave

    mintydave New Member

    Hello all. Thanks for the great product. ISPConfig saves me a bunch of time and I love it.

    This is a new problem for me and I need help fixing it.

    I deleted the first site that was created (web1) from the server (call it
    Then I made the url a website alias which points to

    When I visit, it get stuck in a perpetual loading loop.

    After a little investigation, it turns out there is a default site that get loaded when a client browser requests http with the IP address of the server. With that site gone, I am not able to load a default site on my ISPConfig server.

    And I can't seem to get an alias domain of to load

    I hope that makes sense.

    Any and all assistance would be greatly appreciated.
  2. pititis

    pititis Member

  3. mintydave

    mintydave New Member

    Thank you for the update on that.

    It's certainly not the ideal fix, but it does address part of my problem.

    I will keep my eyes on this bug and hopefully we'll see it permanent fix in an update.

    Deconn Technical Services
  4. mintydave

    mintydave New Member

    I have another issue after I deleted the first site in the domain, the FTP server stopped properly authenticating users.

    I rolled back my ISPConfig server to a previous snapshot I made before I deleted my site. The snapshot had the site intact. Then I simply did a redirect from the "first site" to the new site I am working on. After I applied the fix above I noticed that the FTP server went wacky on me.

    To test, I created a brand new web site under the same customer in question, then a new FTP user.

    I'm not able to authenticate an FTP session to any client, even those that previously worked. FTP is totally broken.

    When I try to log in from a linux command line using the the 'ftp' client directly to the server (same local IP subnet) I get the following in the logs:

    Dec 12 13:05:03 distance vsftpd: pam_unix(vsftpd:auth): check pass; user unknown
    Dec 12 13:05:03 distance vsftpd: pam_unix(vsftpd:auth): authentication failure; logname= uid=0 euid=0 tty=ftp ruser=ftpuser10 rhost=
    Mon Dec 12 13:05:05 2011 [pid 1] [ftpuser10] FAIL LOGIN: Client ""
    I am continuing to research how to remedy this situation. Any comments are greatly appreciated.
  5. mintydave

    mintydave New Member

    Now I'm confused.

    I went back to the installation process and see that PureFTPd was installed, not vsftp.

    I wonder how vsftp got there and why it appears to be running and hijacking FTP requests.

    Thanks for any assistance!!

    Deconn Technical Services.
  6. mintydave

    mintydave New Member

    I fixed this issue but I'm without explanation of what caused it.

    Somehow vsftpd was installed and pure-ftpd-common was uninstalled. Maybe there was some automatic update that I was not aware of... who knows.

    I installed it as:
    apt-get install pure-ftpd-common pure-ftpd-mysql
    Then I verified the /etc/default/pure-ftpd-common file was set to:
    Tried connecting FTP and PureFTPd finally answered the call and got the appropriate banner.

    The fix is good through reboots, so all seems well now.

    We'll chock this one up to full moon or sun spots or something. Case closed.

    Thanks for reading along.

    Deconn Technical Services

Share This Page