1. So I've installed all the way out and have the server functioning properly with only one exception that I've discovered.

    I don't seem to be able to run PHP. No problem during the ISPConfig setup. The problem is when I upload a php file, like the script that is supposed to tell you if php is running. Saved and uploaded as phpinfo.php.

    <? phpinfo();?>

    Every time I try to access the page my browsers (IE, FF, Opera) all ask me if I would like to Open the file with or save as.

    I went through the entire installation process as outlined in The Perfect SuSE setup for 10.2 with absolutely no errors or problems. I have actually performed this setup a number of times because of my own stupid mistakes or GRUB problems. So I am 100% certain that I made no mistakes during this last install.

    I can access the domains I create and any html pages uploaded. Just as an example, www.frankentech.net is currently running a test site and if you'd like to try it the www.frankentech.net/test.php is the current phpinfo file.

    Thanks in advance.
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    If you used ISPConfig: did you set the tick box for php scripts in the site settings for this particular site?
  3. php is enable in ISPConfig for this site. It appears that php5 is not actually running. However, there are no errors in the log other than the warning "unknown filter not added: PHP" or something like that. Which I've found info on that warning and it doesn't seem to be part of the problem.

    I am unable to determine where I can verify what modules are loaded for php in apache2. Or if they are even loaded. I also can't locate a php.ini file, but I may be looking in the wrong places for it.
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    There's a log file in /etc/apache2/error.log. To see what modules are active I use the command
    It will show you the modules active. Just press enter and nothing will change.
  5. If I use -l I get "" not present and -q php5 doesn't display anything.

    I assume that


    APACHE_MODULES="actions alias auth_basic authn_file authz_host authz_groupfile authz_default authz_user authn_dbm autoindex cgi dir env expires include log_config mime negotiation setenvif ssl suexec userdir rewrite"

    Should look pretty much like this, at least according to the Perfect SuSE 10.2 How-To.

    Anywhere else I should check for reasons why php5 isn't loading?
  6. I just removed the extra space just before rewrite in the modules line and tried to restart apache and got this error.

    Syntax error on line 48 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration

    That line currently looks like this:
    php_admin_flag safe_mode Off

    I have PHP Safe mode turned off in ISPConfig for this site.
  7. I am unable to find any reference to what the correct syntax for that line should be or any other direct reference that really seems to help my situation. I have tried a large number of different options to no avail. Please any help would be greatly appreciated.

    The message I posted is the error that I get from trying to restart apache and httpd -t.

    I did manage to find the AddHandler vs AddType information and cannot test it because I cannot restart apache due to the other error about php_admin_flag.

    EDIT: Last attempt for the night. I commented out the php_admin_flag lines in Vhosts and restarted Apache. The php5 modules still don't seem to be loading. Any ideas?
    Last edited: Feb 3, 2007
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please uninstall the php5 module with yast and then reinstall it.

Share This Page