Perfect Spamsnake - libole upgrade issue resolved

Discussion in 'HOWTO-Related Questions' started by jshampur, Jul 14, 2009.

  1. jshampur

    jshampur HowtoForge Supporter

    This may help some other soul, because it caused me a lot of grief:

    Prior to section 7, since mailscanner has an upgrade from when the HOWTO was written, you need to upgrade the libole-storage-lite-perl. You can get this from http://packages.ubuntu.com/intrepid/all/libole-storage-lite-perl/download

    Then install it via dpkg -i libole-storage-lite-perl_0.17-1_all.deb which will upgrade the library to the current version.

    In section 7, the command should read (at least at this time - note the version change)

    wget http://debian.intergenia.de/debian/pool/main/m/mailscanner/mailscanner_4.74.16-1_all.deb

    dpkg -i mailscanner_4.74.16-1_all.deb
     
  2. jsmwalker

    jsmwalker New Member

    Hi thanks for this, can you let me know what steps need to be taken to upgrade the package, or is it a matter of copying the config files and redoing all the settings.

    Also does this solve the issues with the Ignoring deprecated option e.g

    mailscanner WARNING: Ignoring deprecated option --max-ratio

    Thanks in advance.

    J
     
  3. jshampur

    jshampur HowtoForge Supporter

    I did not receive that error - at what step did you get that error message?

    Thanks.
     
  4. jsmwalker

    jsmwalker New Member

    Hi, think I confused this slightly, this error was received on the old version of mailscanner, but have upgraded to the new version and those errors do not seem to appear, so all looks good.

    I did the upgrade and just took a backup of the original config, and then copied back the MailScanner.conf and spamassassin.conf.pref files and all seems to work ok, not sure if this was the correct way to do this, please let me know if I missed anything.

    Cheers

    J
     

Share This Page