Perfect SpamSnake 10.10 - nginx install..

Discussion in 'HOWTO-Related Questions' started by colskinet, Dec 18, 2010.

  1. colskinet

    colskinet New Member

    I've got to installing nginx and am trying to retrieve the files to allow me to install nginx using the following commands:

    9. Nginx with Uwsgi
    Download and install both Nginx and Uwsgi from Chris Lea’s Launchpad:

    wget https://launchpad.net/~chris-lea/ archive/nginx-devel/ files/nginx_0.8.53-1chl1~maverick1_ $(uname -m | sed -e 's/x86_64/amd64/' -e 's/i686/i386/').deb
    wget https://launchpad.net/~chris-lea/ a.../ files/uwsgi-common_0.9.6.5-1chl1~maverick1_ $(uname -m | sed -e 's/x86_64/amd64/' -e 's/i686/i386/').deb
    wget https://launchpad.net/~chris-lea/ a...1/ files/uwsgi-extra_0.9.6.5-1chl1~maverick1_ $(uname -m | sed -e 's/x86_64/amd64/' -e 's/i686/i386/').deb
    wget https://launchpad.net/~chris-lea/ a...iles/uwsgi-python2.6_0.9.6.5-1chl1~maverick1_ $(uname -m | sed -e 's/x86_64/amd64/' -e 's/i686/i386/').deb
    wget https://launchpad.net/~chris-lea/ a.../ files/uwsgi_0.9.6.5-1chl1~maverick1_all.deb
    apt-get install libsctp1
    dpkg -i nginx*
    dpkg -i uwsgi*

    However, the system is returning the following error:

    --2010-12-18 11:20:31-- https://launchpad.net/~chris-lea/ archive/nginx-devel/ files/nginx_0.8.53-1chl1~maverick1_
    Resolving launchpad.net... 91.189.89.223, 91.189.89.222
    Connecting to launchpad.net|91.189.89.223|:443... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2010-12-18 11:20:31 ERROR 404: Not Found.

    --2010-12-18 11:20:31-- http://amd64.deb/
    Resolving amd64.deb... failed: Name or service not known.
    wget: unable to resolve host address `amd64.deb'

    This happens on all of the files that I need to retrieve! I've tried copying and pasting, typing it in manually but still it won't work.

    Anyone?!

    Colin
     
  2. topdog

    topdog New Member HowtoForge Supporter

    Remove the space between _ and $(uname....
     
  3. colskinet

    colskinet New Member

    Hi topdog!

    Just tried that and I then get a 404 not found error.

    Looking at https://launchpad.net/~chris-lea/ archive/nginx-devel/ I see it is now version 0.9.3 - assume it's safe to get that version instead?

    Thanks again
    Colin
     
  4. Rocky

    Rocky New Member

    Nginx was revised and a new version was release. I've updated the link in the guide.

    It should work fine with the new version.
     
  5. thbe

    thbe New Member


    It seems that uwsgi is not available anymore. I can't find it on their website. What now? I'm stuck here!

    thomas
     
  6. colskinet

    colskinet New Member


    If you go to https://launchpad.net/~chris-lea/ archive/uwsgi/ packages in a web browser, then expand the selection for whatever version of Ubuntu you are using (mine was Maverick as per the guide), you'll then see the files. I right clicked on the ones I wanted, then done a "save as". Once I had them on my PC, I then moved them to my spamsnake server.

    It worked for me anyway!

    Good luck!


    EDIT - changing the path to wget https://launchpad.net/~chris-lea/+archive/uwsgi/+files/uwsgi-common_0.9.6.5-1chl1~maverick1_$(uname -m | sed -e 's/x86_64/amd64/' -e 's/i686/i386/').deb was successful in finding the files.. (taking out "+build/2038401/" in the original path..)
    Colin
     
    Last edited: Jan 9, 2011
  7. thbe

    thbe New Member

    Thanks! Found it but now I have a "Gateway error" in the webbrowser.

    I'll think I will start it all over again. Have messed up things perhaps :-(
     
  8. Rocky

    Rocky New Member

    Yes, the gateway error points to uwsgi not working as expected.
     

Share This Page