Perfect setup suse 10.1

Discussion in 'HOWTO-Related Questions' started by alexillsley, Dec 13, 2006.

  1. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Hi,
    I was just going through your how to, to set up a server on Suse 10.1 and it was all going really well till i hit a problem:

    When i get to the point of installing an smpt server then testing with telnet i get absoultley no response when i type it in the command line i get this result:
    server1:#Telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is ']'
    echlo localhost


    Then i get no response. Have you got any ideas what i have done wrong and or how can i fix this?

    Your help would be really really apreciated!
    Thanks,
    Alex
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You mistyped the last command, it must be:

    ehlo localhost

    and not:

    echlo localhost
     
  3. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    sorry i did type that, i typed it wrong when posting on the forum. Any ideas? any help would be really apreciated!
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/postfix/main.cf (please strip out the comments)?
     
  5. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Thanks for quick reply here is what is in main.cf:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/lib/postfix
    mail_owner = postfix
    unknown_local_recipient_reject_code = 550
    sendmail_path = /usr/sbin/sendmail
    mailq_path = /usr/bin/mailq
    setgid_group = maildrop
    html_directory = /usr/share/doc/packages/postfix/html
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/packages/postfix/samples
    readme_directory = /usr/share/doc/packages/postfix/README_FILES
    inet_protocols = all
    biff = no
    mail_spool_directory = /var/mail
    canonical_maps = hash:/etc/postfix/canonical
    virtual_alias_maps = hash:/etc/postfix/virtual
    virtual_alias_domains = hash:/etc/postfix/virtual
    relocated_maps = hash:/etc/postfix/relocated
    transport_maps = hash:/etc/postfix/transport
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    masquerade_exceptions = root
    masquerade_classes = envelope_sender, header_sender, header_recipient
    myhostname = server1.$mydomain
    program_directory = /usr/lib/postfix
    inet_interfaces = all
    masquerade_domains =
    mydestination = $myhostname, localhost.$mydomain
    defer_transports =
    mynetworks_style = subnet
    disable_dns_lookups = no
    relayhost =
    mailbox_command =
    mailbox_transport =
    strict_8bitmime = no
    disable_mime_output_conversion = no
    smtpd_sender_restrictions = hash:/etc/postfix/access
    smtpd_client_restrictions =
    smtpd_helo_required = no
    smtpd_helo_restrictions =
    strict_rfc821_envelopes = no
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
    smtp_sasl_auth_enable = no
    smtpd_sasl_auth_enable = yes
    smtpd_use_tls = yes
    smtp_use_tls = yes
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000
    mydomain = *****.co,uk
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_tls_auth_only = no
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom


    Here is the full uncommented version: removed_now/main.txt
     
    Last edited: Apr 23, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/hosts?

    Please create an A record for server1.fireproductions.co.uk:

    Code:
    mh1:~# dig server1.fireproductions.co.uk
    
    ; <<>> DiG 9.2.1 <<>> server1.fireproductions.co.uk
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 51109
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server1.fireproductions.co.uk. IN      A
    
    ;; AUTHORITY SECTION:
    fireproductions.co.uk.  3600    IN      SOA     ns1.awardspace.com. hostmaster.awardspace.com. 2006032101 10800 3600 1209600 7200
    
    ;; Query time: 517 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Fri Dec 15 13:10:14 2006
    ;; MSG SIZE  rcvd: 112
     
  7. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    I currently have a dynamic ip at the moment so i cannot set the A record :(
     
  8. falko

    falko Super Moderator ISPConfig Developer

    You could get yourself a dyndns.org domain and make server1.fireproductions.co.uk a CNAME of it.
     
  9. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Before i do that how can i get my mailserver to respond
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in the mail logfile in /var/log/ ?
     
  11. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    I ran the commands to test it and i looked in the mail log file afterwards and and some errors apeared in it heres is a snippet of the log file when i get the errors
    Code:
    Dec 16 13:02:30 server1 postfix/postfix-script: refreshing the Postfix mail system
    Dec 16 13:02:30 server1 postfix/master[3389]: reload configuration /etc/postfix
    Dec 16 16:50:26 server1 postfix/smtpd[11206]: warning: unsupported SASL server implementation: cyrus
    Dec 16 16:50:26 server1 postfix/smtpd[11206]: fatal: SASL per-process initialization failed
    Dec 16 16:50:27 server1 postfix/master[3389]: warning: process /usr/lib/postfix/smtpd pid 11206 exit status 1
    Dec 16 16:50:27 server1 postfix/master[3389]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please redo the steps for the sasl and postfix configuration of the howto abd then try again the test.
     
  13. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    When i try to to install it again i get a service already provided error, is this becuase i am running an lampp server at the moment? should i unistall it?

    it would not let me post the error, so i put it an an image
    [​IMG]

    I can give someone VNC access if they could help me to get it all working?

    I really apreciate all your help,
    Alex
     
    Last edited: Dec 17, 2006
  14. falko

    falko Super Moderator ISPConfig Developer

  15. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Still no repsonse:confused: i have given till SSH access hopfully he can fix it
     
  16. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    I have given up, i have started again installed OpenSUSE 10.2 and going through the tutorial for it. I am having problems now with updating it when i goto "online update" in the install it says "No products to register" is that fine? should i just leave it?
    Thanks,
    Alex

    Edit: Think i have fixed it :)
     
    Last edited: Dec 22, 2006

Share This Page