Perfect setup madriva 2007 and Postfix

Discussion in 'HOWTO-Related Questions' started by wiremeister, Jan 22, 2007.

  1. wiremeister

    wiremeister New Member

    Have a problem logging in to the Pop3 server through Outlook, and cannot find any emails received through webmail. Maildir is checked in ISPConfig.

    An excerpt from the mail log (below) would seem to show that an email was recieved and then removed from the queue? If so, this would explain why I can't find any messages..... :confused:

    From /var/log/mail/info:

    Jan 21 19:58:53 ns3 ipop3d[2098]: pop3 service init from 192.168.1.88
    Jan 21 19:58:53 ns3 ipop3d[2098]: Login user=sheltiehosting.com host=[192.168.1.88] nmsgs=0/0
    Jan 21 19:58:53 ns3 ipop3d[2098]: Logout user=sheltiehosting.com host=[192.168.1.88] nmsgs=0 ndele=0
    Jan 21 19:59:25 ns3 postfix/smtpd[2095]: connect from unknown[192.168.1.88]
    Jan 21 19:59:26 ns3 postfix/smtpd[2095]: 7DF98141850: client=unknown[192.168.1.88], sasl_method=LOGIN, sasl_username=sheltiehosting.com
    Jan 21 19:59:26 ns3 postfix/cleanup[2101]: 7DF98141850: message-id=<001401c73dd1$55d1cae0$5801a8c0@DADLAPTOP>
    Jan 21 19:59:26 ns3 postfix/qmgr[30221]: 7DF98141850: from=<webmaster@sheltiehosting.com>, size=3120, nrcpt=1 (queue active)
    Jan 21 19:59:26 ns3 postfix/local[2102]: 7DF98141850: to=<sheltiehosting.net@ns3.sheltiehosting.com>, orig_to=<webmaster@sheltiehosting.net>, relay=local, delay=0.18, delays=0.12/0/0/0.06, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jan 21 19:59:26 ns3 postfix/qmgr[30221]: 7DF98141850: removed
    Jan 21 19:59:28 ns3 postfix/smtpd[2095]: disconnect from unknown[192.168.1.88]

    Authentication for SMTP is checked in outlook, so we can send emails without a problem outside. Just can't log on to the Pop3 server to retrieve emails that we cannot find......:rolleyes:

    Main.cf:

    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    html_directory = /usr/share/doc/postfix-2.3.3/html
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    command_directory = /usr/sbin
    manpage_directory = /usr/share/man
    daemon_directory = /usr/lib/postfix
    newaliases_path = /usr/bin/newaliases
    mailq_path = /usr/bin/mailq
    queue_directory = /var/spool/postfix
    mail_owner = postfix

    # User configurable parameters

    inet_interfaces = all
    mynetworks_style = host
    #delay_warning_time = 4h
    smtpd_banner = $myhostname ESMTP $mail_name ($mail_version) (Mandriva Linux)
    unknown_local_recipient_reject_code = 450
    smtp-filter_destination_concurrency_limit = 2
    lmtp-filter_destination_concurrency_limit = 2
    recipient_delimiter = +
    owner_request_special = no
    alias_maps = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mydomain = sheltiehosting.com
    myhostname = ns3.$mydomain
    mydestination = /etc/postfix/local-host-names, localhost.sheltiehosting.com
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable
    smtp_host_lookup = dns, native
    mynetworks = 127.0.0.0/8

    And netstat -tap:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 16743/xinetd
    tcp 0 0 *:mysql-im *:* LISTEN 3464/mysqlmanager
    tcp 0 0 *:nfs *:* LISTEN -
    tcp 0 0 *:pop3s *:* LISTEN 16743/xinetd
    tcp 0 0 localhost.localdomain:10026 *:* LISTEN 30219/master
    tcp 0 0 *:mysql *:* LISTEN 3491/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN 3773/smbd
    tcp 0 0 *:876 *:* LISTEN 3269/rpc.mountd
    tcp 0 0 *:pop3 *:* LISTEN 16743/xinetd
    tcp 0 0 *:imap *:* LISTEN 16743/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 2775/portmap
    tcp 0 0 *:http *:* LISTEN 4597/httpd
    tcp 0 0 *:10000 *:* LISTEN 3679/perl
    tcp 0 0 ns3.sheltiehosting.co:10000 192.168.1.88:2513 SYN_RECV -
    tcp 0 0 *:x11 *:* LISTEN 3049/X
    tcp 0 0 *:54288 *:* LISTEN -
    tcp 0 0 *:784 *:* LISTEN 3158/rpc.rquotad
    tcp 0 0 *:81 *:* LISTEN 4184/ispconfig_http
    tcp 0 0 ns3.sheltiehosting.c:domain *:* LISTEN 32043/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 32043/named
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 32043/named
    tcp 0 0 *:smtp *:* LISTEN 30219/master
    tcp 0 0 *:59194 *:* LISTEN 2983/rpc.statd
    tcp 0 0 *:https *:* LISTEN 4597/httpd
    tcp 0 0 *:7741 *:* LISTEN 4050/lisa
    tcp 0 0 *:microsoft-ds *:* LISTEN 3773/smbd
    tcp 0 0 ns3.sheltiehosting.com:http 192.168.1.174:1960 TIME_WAIT -
    tcp 0 0 ns3.sheltiehosting.com:http 192.168.1.174:1963 TIME_WAIT -
    tcp 0 0 ns3.sheltiehosting.com:http 192.168.1.174:1957 TIME_WAIT -
    tcp 0 0 ns3.sheltiehosting.co:10000 192.168.1.88:2518 ESTABLISHED 2347/index.cgi
    tcp 0 0 *:x11 *:* LISTEN 3049/X
    tcp 0 0 *:ftp *:* LISTEN 4778/proftpd: (acce
    tcp 0 0 *:ssh *:* LISTEN 3037/sshd
    tcp 0 0 localhost:rndc *:* LISTEN 32043/named

    Any ideas? Thanks!

    Well, found the emails here: /var/www/web1/user/sheltiehosting.com/Maildir/new. Though I'm at a loss as to why Webmail, Squirrelmail, or Outlook can't retrive them........
     
    Last edited: Jan 22, 2007
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please unselect the Maildir checkbox in ISPCOnfig. Your POP3 Daemon does not support maildir.
     
  3. wiremeister

    wiremeister New Member

    Thanks for your reply Till.

    Maildir is unchecked, and I have restarted Postfix. Outlook is still unable to log in to the pop3 server. Outlook was able to send a test email, and I have verified reciept of that email using webmin, but it does not come up in outlook. Webmail and Squirrelmail also show an empty inbox.

    Any thoughts on that?
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please send the mails again. The old ones are now located in Maildir, but your POP3 server requires mbox. Now that Maildir is unchecked in ISPConfig, new mails will be delivered to mbox.
     
  5. wiremeister

    wiremeister New Member

    Hi Falko,

    Thanks. Located the new files. Any emails recieved are bounced back with the following attached:

    The mail system

    <sheltiehosting.com@ns3.sheltiehosting.com> (expanded from
    <webmaster@sheltiehosting.com>): service unavailable. Command output:
    ==================== QUOTA: 0 INBOXSIZE: 0 Bouncing (inbox already
    full!) /bin/sh: line 2: -oi: command not found

    I can imagine there would be a setting somewhere to be changed? There are currently no emails in any mailbox. Where to look? :confused:
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Do you have quota and quotatools installed?
     
  7. wiremeister

    wiremeister New Member

    Hello Till,

    Yes. Installed using Perfect Setup Mandriva 2007. Near as I can tell quota is enabled. Quotatools I'm not certain about. Was that part of the Setup? I do not see a package named quotatools.....

    Yes. quota-3.13-2mdk.i586.rpm is installed and running.

    Turned quotas off, then ran quotacheck, and turned quotas back on (followed Setup again). Sent another email, and it bounced as before. Same message.
     
    Last edited: Jan 22, 2007
  8. wiremeister

    wiremeister New Member

    Hi Till, and Falko,

    Problem solved. Reloaded the server to do it, but at least email works now. Something got munched somewhere..... Thanks very much for your help!
     

Share This Page