Perfect setup (debian sarge)

Discussion in 'Installation/Configuration' started by Pelle, Oct 10, 2005.

  1. Pelle

    Pelle New Member

    Hey,

    After alot of problems with my last installation, I will now try to follow the guide total.

    The only differences on my debian sarge is that is running on kernel 2.4.30 because I cant kompile a 2.6 kernel that dosent panic because of my sata drives, and if reconize the first drive then the second will not work?!

    But thats is not the reason of my post here.

    I have come to the point of installing Apache2 + PHP.

    Apache2 is installing:

    Code:
    The following extra packages will be installed:
      apache2-common apache2-mpm-worker apache2-utils libapr0 libexpat1 ssl-cert
    The following NEW packages will be installed:
      apache2 apache2-common apache2-doc apache2-mpm-worker apache2-utils libapr0 libexpat1 ssl-cert
    
    And it working, then the next step, installing PHP4.

    Code:
     > apt-get install libapache2-mod-php4 libapache2-mod-perl2 php4 php4-cli php4-common php4-curl php4-dev php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear php4-xslt curl libwww-perl imagemagick
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libapache2-mod-perl2: Depends: libperl5.8 (>= 5.8.4) but it is not going to be installed
      php4-dev: Depends: libssl-dev but it is not going to be installed
    E: Broken packages
    
    I will try install libperl5.8 by apt-get install libperl5.8:
    (cut out the rest of apt-gets output but this.
    Code:
    The following packages have unmet dependencies:
      libperl5.8: Depends: perl-base (= 5.8.4-8) but 5.8.7-3 is to be installed
    E: Broken packages
    

    Then I try installing perl-base
    Code:
    perl-base is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    
    my /etc/apt/sources.list
    Code:
    deb http://ftp-mirror.internap.com/pub/debian/ stable main
    deb-src http://ftp-mirror.internap.com/pub/debian/ stable main
    deb http://non-us.debian.org/debian-non-US stable/non-US main
    deb-src http://non-us.debian.org/debian-non-US stable/non-US main
    
    deb http://ftp.us.debian.org/debian/ stable main
    deb-src http://ftp.us.debian.org/debian/ stable main
    deb http://non-us.debian.org/debian-non-US stable/non-US main
    deb-src http://non-us.debian.org/debian-non-US stable/non-US main
    
    deb http://security.debian.org/ stable/updates main
    
    deb http://debian.crosslink.net/debian/ stable main
    deb-src http://debian.crosslink.net/debian/ stable main
    
    deb http://mirrors.sunsite.dk/debian/ stable main
    deb-src http://mirrors.sunsite.dk/debian/ stable main
    
    Could anybody help me please.
     
  2. falko

    falko Super Moderator

    This is my /etc/apt/sources.list:
    Code:
    #deb file:///cdrom/ sarge main
    
    deb http://ftp2.de.debian.org/debian/ stable main
    deb-src http://ftp2.de.debian.org/debian/ stable main
    
    deb http://security.debian.org/ stable/updates main
    Can you try that one (run
    Code:
    apt-get update 
    after you've changed /etc/apt/sources.list!)?
     
  3. Pelle

    Pelle New Member

    It dosent work either.

    Code:
      libperl5.8: Depends: perl-base (= 5.8.4-8) but 5.8.7-3 is to be installed
      libssl-dev: Depends: libssl0.9.7 (= 0.9.7e-3) but 0.9.7g-2 is to be installed
    
     
  4. falko

    falko Super Moderator

    Maybe you should consider a clean re-install...
     
  5. Pelle

    Pelle New Member

    Hey Falko,

    I have just made a clean reinstall!

    And their must be a way of avoiding that, because its 25usd out of the window everytime (have a dedicated server at a host) so havent got "access" to the machine, only thru SSH.
     

Share This Page