Perfect Setup Centos 4.4 MySQL Error

Discussion in 'Installation/Configuration' started by formadmirer, Apr 13, 2007.

  1. formadmirer

    formadmirer New Member

    http://www.howtoforge.com/perfect_setup_centos_4.4_p4

    This is the 4th time I have tried to go through this setup and every time I get hung at the bottom of the 4th page.

    These are the two lines I cannot get past...
    --------
    mysqladmin -u root password yourrootsqlpassword
    mysqladmin -h server1.example.com -u root password yourrootsqlpassword

    -------

    The first line executes without a problem. So the root password is set.
    But line 2 fails every single time I get to it.

    The error I get is:
    mysqladmin: connect to server at 'www.mydomain.com' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'

    There have been no other errors of any kind up until this point.

    The first time I went through the setup I couldn't get past here and finally just ignored the error and went on. Needless to say that came back to bite me before the install was complete.
    So I started again. The second time I could'nt get past it either. This was several weeks ago and I had just given up until I had some spare time tonight.
    Tonight I've tried it twice (with around 4 hours invested) - and twice I got the same thing.

    Does anyone know what the problem is and has anyone else gotten through this part and if so - how?? :(

    For the record - I LOVE the tutorial, very easy to follow with clear instructions - thank you! I just would love to acutally get to use it. :)
     
  2. till

    till Super Moderator

    You can skip the second command and proceed with the next steps. After you finished the installation, check with phpmyadmin if a password is set for all root user accounts.
     
  3. formadmirer

    formadmirer New Member

    Installed!

    Did as instructed - and Success! Thank you. :)
    Normally, from past experiences, when something fails during an install I abort and start over. Live and learn.
     

Share This Page