Perfect Server Ubuntu 9.10 with ISPConfig3

Discussion in 'Server Operation' started by hccoder, Nov 6, 2009.

  1. hccoder

    hccoder New Member


    First: Sorry for my english,

    Second: the real problem, yesterday i setup an ubuntu 9.10 server with ISPConfig3, like in here:
    After installation everything's good, I started setting up the domains what I handle. After I setup 2 domain I started testing:
    I was send a mail to [email protected], after this, I checked the virtualuser's mailbox and the mail was there.
    In the next step I send a mail to [email protected] this is my mailbox, and the gmail gives me an error message after sending, that's contains the following lines:

    'This is the mail system at host

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system

    <[email protected]>: unknown user: "admin"

    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.1.1
    Diagnostic-Code: X-Postfix; unknown user: "admin"'

    I think postfix wanna send this E-Mail to a localuser called admin, but I have only vitrualusers, i don't know how I can fix this problem :(.
    My access to ISPConfig panel is

    I welcome any idea! :)
    Thanks a lot.
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/
  3. hccoder

    hccoder New Member


    # See /usr/share/postfix/ for a commented, more complete version

    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    readme_directory = /usr/share/doc/postfix

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname =
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination =, localhost, localhost.localdomain
    relayhost =
    mynetworks = [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/, mysql:/etc/postfix/
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/, reject_unauth_destination
    smtpd_tls_security_level = may
    transport_maps = proxy:mysql:/etc/postfix/
    relay_domains = mysql:/etc/postfix/
    virtual_create_maildirsize = yes
    virtual_maildir_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = maildrop
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    content_filter = amavis:[]:10024
    receive_override_options = no_address_mappings

    I've never touch this config, it's generated by ISPconfig(I think).
    Last edited: Nov 6, 2009
  4. falko

    falko Super Moderator ISPConfig Developer

    Is listed anywhere in your or in /etc/mailname?

    Does the MX record for point to the correct server? You can check that with
    dig mx
  5. hccoder

    hccoder New Member

    Thank you!

    Today I will reinstall my system, I think I did some mistakes. :confused:
  6. hccoder

    hccoder New Member


    I',ve reinstalled my system(, and everything is OK, but I need 1 more thing, if I wanna use the SMTP, i cannot login with my username and password(tried with ssl,tls doesn't help), but if I send mail to myself or other mail users on the server it's working without smtp login :confused:
    Anyone can tell me how can I change this? I need to able login to SMTP from everywhere, and need to send mail to everyone :rolleyes:

    Thank you!

    Edit: I've changed the SMTP port to 2500 because my ISP is blocking port 25, and I can telnet into my server with port 2500
    Last edited: Nov 10, 2009
  7. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log? Did you use the email address as the SMTP username?
  8. hccoder

    hccoder New Member

    Yes I used my email address as SMTP login name, and if I set the recipient address in the whitelist I can send mail to that address, but only for this one...
    I tried to set my email address to 'sender' in whitelist but nothing happen, postfix gives me an error 'relay access denied'...
  9. hccoder

    hccoder New Member

    I've resolved the problem, changed the smtp chroot in the to y and it works fine! :)

    Thanks again!

Share This Page