Perfect Server Ubuntu 7.10 - accessing ISPConfig

Discussion in 'HOWTO-Related Questions' started by BrandonsLinux, Nov 21, 2007.

  1. BrandonsLinux

    BrandonsLinux New Member

    So I have set my server up exactly how described in the tutorial (with the exception of a plain SMTP auth that I will ask about later), and I even installed ISPConfig with no problems (got a PHP binary mismatch in expert installation mode, but the second time it worked fine). Now that I have everything installed, I want to dive in to it and play around.

    I am on my Vista machine (behind the same router), and if I type in http://www.192.168.1.1/, I can see my server and see my test files. However, if I type in http://server1.example.com, it obviously tries to resolve example.com. I went in to Vista's HOSTS file and added the following record:
    Code:
    192.168.1.100   server1.example.com
    Cool, now I can access http://server1.example.com, no problems. However, https://server1.example.com:81 does not resolve (I opted for the HTTPS connection at setup). If I remove the https, server1.example.com:81 results in a server error page that says Bad request, try https...

    What setting am I messing up? Is it a Vista setting or something in Ubuntu/ISPConfig?

    Thanks!
     
  2. BrandonsLinux

    BrandonsLinux New Member

    So I just found what might be a big problem. When I reboot my server, it prompts me for my RSA encryption pass phrase (which I didn't know that it was optional in setup and I would like to remove). However, when I enter in the pass phrase, it says "Login incorrect". If I watch closely, I think that a script is firing off and entering in a lot of details as my login (username). I'm not sure if this is causing ISPConfig to not load properly or what. I don't know how to fix this either.

    Also, the last line of the boot screen is
    Code:
     * Running local boot scripts (/etc/rc.local)       [OK]
    , but then it sticks. In order to get the command prompt, I have to hit enter.

    I was hoping for a box that doesn't require me to do anything every time I restart it. Is there any way to fix these errors? Are they related to the ISPConfig problem I described in my first post?

    Thanks.
     
  3. till

    till Super Moderator

  4. BrandonsLinux

    BrandonsLinux New Member

    You're borderline amazing. Two birds with one stone. Thanks!
     

Share This Page