Perfect server Ubuntu 10.10 squirrelmail problem

Discussion in 'HOWTO-Related Questions' started by swampy1979, Mar 18, 2011.

  1. swampy1979

    swampy1979 New Member

    Hello everyone,

    I have followed the perfect server guide recently for ubuntu 10.10, and before that on my old install perfect server 10.04.:D Awesome!

    Anyway to the point, I've set the server up with 3 domains within ISPconfig3 e.g.
    myserver1.com
    myserver2.com
    myserver3.com

    and my default domain being myserver.com

    What I'm trying to do is add a symlink to each one for webmail e.g.
    ln -s /usr/share/squirrelmail/ /var/www/myserver1.com/web/webmail

    Now herein lies the problem, if I go to http://myserver1.com/webmail
    I get the error:
    ERROR: Config file "config/config.php" not found. You need to configure SquirrelMail before you can use it.

    However, I have configured squirrelmail and it works fine if I go to myserver.com/webmail which uses the default /var/www/webmail symlink

    I'm afraid I'm completely stumped as to what to try, I would have thought if the symlinks both go to the same place everything would work as expected.

    On my previous install I didn't have this problem, well not that I remember anyway! and I didn't back it up before installing ubuntu 10.10 (a lesson learnt, my bad!) I have looked at the permissions and as far as I can see there is no difference between the 2 symlinks :confused:

    I'm well and truly stuck, and would be eternally grateful if one of you linux gurus could help me out here, I'm sure I'm probably missing something really obvious.

    Thanks in advance
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. swampy1979

    swampy1979 New Member

    Now getting a different error???

    Hi Falko,

    Thank you so much for your help it's really appreciated!

    I have followed the guide to the letter, and now get a different error.

    When I browse to either

    myserver1.com/webmail

    or

    myserver1.com/squirrelmail

    I get:

    You have chosen to open
    which is a: application/x-httpd-suphp

    The browser is trying to download the file not open it, however if I go to:
    myserver1.com:8080/webmail then it does work and I can log in.

    I don't know what I'm missing and would very much appreciate any further assistance and or a short description of why this is happening to help me learn.

    Thanks again :)
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you enable PHP for your web sites?
     
  5. swehes

    swehes New Member

    Falko,

    I have the same issue as the guy above. And I have PHP enabled. And I still get the same issue. It works when I try to get to the webmail through the main server but as soon as I try to access it from any of the domain's I get the box that says "You have chosen to open which is a: application/x-httpd-suphp from: http://mydomain.com

    I don't know what to do with this.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Does it work through mod_php?
     
  7. rushpower

    rushpower New Member

    What was the outcome of this issue? i just bumped into the same problem.
     

Share This Page