Perfect Server, OpenSUSE 13.1 connecting to ipsconfig, NOT to squirrelmail/phpmyadmin

Discussion in 'ISPConfig 3 Priority Support' started by rupertrealbear, Nov 21, 2014.

  1. rupertrealbear

    rupertrealbear New Member

    openSUSE 13.1 x86_64
    ISPConfig version is

    I followed The Perfect Server - OpenSUSE 13.1 x86_64 (Apache2, MySQL, PHP, Postfix, Dovecot and ISPConfig 3), but WITHOUT configuring a static IP [as I didn't have one] - so left I it configured for DCHP.

    I commented out the lines beginning "php_admin_flag . . " in /etc/apache2/conf.d/squirrelmail.conf

    I have connected to ISPConfig, through which I have created a client and a website. Within the client, I have created an email domain and a mailbox.

    The admin login of ISPconfig > Monitor > Server State mentions . . "All needed services are online"

    http://[external IP]/phpmyadmin

    is " . . not available" and neither is

    http://[external IP]/squirrelmail

    I have added my internal IP to /etc/hosts:-
    Code:    server1
    When navigating to

    or to

    the browser downloads [rather than rendering] the index web page - written in PHP.

    The ISPConfig test script outputs:-
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [INFO] ISPConfig is installed.
    ##### ISPCONFIG #####
    ISPConfig version is
    ##### VERSION CHECK #####
    [INFO] php (cli) version is 5.4.20
    ##### PORT CHECK #####
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening
    ##### MAIL SERVER CHECK #####
    [WARN] I found no "submission" entry in your postfix
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.
    [INFO] I found the following web server(s):
    	Unknown process (httpd2-prefork) (PID 1703)
    [INFO] I found the following mail server(s):
    	Postfix (PID 2013)
    [INFO] I found the following pop3 server(s):
    	Dovecot (PID 1461)
    [INFO] I found the following imap server(s):
    	Dovecot (PID 1461)
    [INFO] I found the following ftp server(s):
    	PureFTP (PID 1460)
    ##### LISTENING PORTS #####
    (only		()
    Local		(Address)
    ***.***.***.***:53		(1642/named)
    [localhost]:53		(1642/named)
    [anywhere]:21		(1460/pure-ftpd)
    [anywhere]:22		(1467/sshd)
    [anywhere]:25		(2013/master)
    [localhost]:953		(1642/named)
    [anywhere]:993		(1461/dovecot)
    [anywhere]:995		(1461/dovecot)
    [localhost]:10024		(1935/amavisd)
    [localhost]:9000		(1572/php-fpm.conf))
    [localhost]:10025		(2013/master)
    [anywhere]:110		(1461/dovecot)
    [anywhere]:143		(1461/dovecot)
    *:*:*:*::*:53		(1642/named)
    *:*:*:*::*:21		(1460/pure-ftpd)
    *:*:*:*::*:22		(1467/sshd)
    *:*:*:*::*:25		(2013/master)
    *:*:*:*::*:953		(1642/named)
    *:*:*:*::*:443		(1703/httpd2-prefork)
    *:*:*:*::*:993		(1461/dovecot)
    *:*:*:*::*:995		(1461/dovecot)
    *:*:*:*::*:10024		(1935/amavisd)
    *:*:*:*::*:3306		(1890/mysqld)
    [localhost]10		(1461/dovecot)
    [localhost]43		(1461/dovecot)
    *:*:*:*::*:8080		(1703/httpd2-prefork)
    *:*:*:*::*:80		(1703/httpd2-prefork)
    *:*:*:*::*:8081		(1703/httpd2-prefork)
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination         
    Because the report said " . . Port 465 (SMTP server SSL) seems NOT to be listening . . ", I port-forwarded port 465 TCP to the internal IP of the server, but it didn't help. I don't feel confident to tinker any further.

    Can anybody advise?

    Thanks in advance

  2. rupertrealbear

    rupertrealbear New Member

    Hello again

    I neglected to mention that I had set up DNS services thru

    In the meantime, I found howtoforge tutorial How To Install No-ip2 On Ubuntu 12.04 LTS In Order To Host Servers On A Dynamic IP Address.

    I already installed and ran the Dynamic DNS Update Client (DUC) for Linux from and, from the above tutorial and also from the knowledgebase, I port-forwarded:-

    port 20-22 TCP
    port 80 TCP
    port 443 TCP
    port 8245 TCP&UDP

    to my internal IP

    I now find that my domain [managed by]


    renders the default "Welcome!" index page provided by ispconfig.

    I created an FTP account which connects on


    although it fails to retrieve the directory listing [/srv/www/clients/client1/web1] and then disconnects (something I will look into later).

    I now find that with


    and with


    the browser downloads [rather than rendering] the web page.

    There does not seem to be anything missing|extra in the updated ISPConfig test script output.

    So far, any progress made seems to from changes OTHER than in ISPConfig


  3. till

    till Super Moderator Staff Member ISPConfig Developer

    When you run a webserver behind a router, then the internal IP is used for the websites (apache) and the external IP is used in dns. the translation between internal and external IP is done by the router.

    Regarding phpmyadmin and webmail, most likely the apache mod_php module is not installed or it is not enabled in apache.
  4. rupertrealbear

    rupertrealbear New Member

    Thanks Till,

    I have tried re-installing a couple of times. I was finding it very difficult to ensure that mod_php is enabled.

    I am assuming that mod_php gets installed with the inclusion of:-
    zypper install . . . apache2-mod_php5 
    in step 10.

    In the end, I found that including:-
    a2enmod php5
    enabled the module, so that running:-
    apache2ctl -M
    finally included php5_module (shared) and . . .


    . . and . . .


    . . . triumphantly enter their login screens! :D



    p.s. now to investigate why I can login to my ftp account, but NOT get a directory listing (which I am assuming is about permissions)

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not very likely that the directory permissions are wrong as they are hardcoded in ispconfig and working on so many servers. Check if the web user (that owns the website directory) really exists in /etc/passwd and take a look at the log files if pure-ftpd throws any errors.
  6. rupertrealbear

    rupertrealbear New Member

    Hi Till,

    I don't think there is any error.

    In /etc/passwd there is an entry:-
    Pure-ftpd FAQ suggested various log file to search for ftp errors [none of which I found on my openSUSE], however, /var/log/messages has the entries:-
    2014-11-25T18:45:02.142709+00:00 server1 pure-ftpd: (?@::1) [INFO] New connection from ::1
    2014-11-25T18:45:02.143419+00:00 server1 pure-ftpd: (?@::1) [INFO] Logout.
    My Filezilla client message log has the output:-
    Resolving address of ftp.domain.tld
    Status:	Connecting to ***.***.***.***:21...
    Status:	Connection established, waiting for welcome message...
    Response:	220-Welcome to Pure-FTPd.
    Response:	220-You are user number 1 of 10 allowed.
    Response:	220-Local time is now 17:59. Server port: 21.
    Response:	220-This is a private system - No anonymous login
    Response:	220-IPv6 connections are also welcome on this server.
    Response:	220 You will be disconnected after 15 minutes of inactivity.
    Command:	USER [client][user]
    Response:	331 User [client][user] OK. Password required
    Command:	PASS ********
    Response:	230 OK. Current restricted directory is /
    Command:	OPTS UTF8 ON
    Response:	200 OK, UTF-8 enabled
    Status:	Connected
    Status:	Retrieving directory listing...
    Command:	PWD
    Response:	257 "/" is your current location
    Command:	TYPE I
    Response:	200 TYPE is now 8-bit binary
    Command:	PASV
    Response:	227 Entering Passive Mode (192,168,0,6,28,64)
    Status:	Server sent passive reply with unroutable address. Using server address instead.
    Command:	MLSD
    Error:	Connection timed out
    Error:	Failed to retrieve directory listing
    Is this all something for Filezilla support ?


  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Just a guess, do you have activated a firewall? I guess the problem is that the passive port range of pure-ftpd and the one in your firewall dont match, so after your client switched to passive ports, it could not reach te server anymore as the passive port is closed in the firewall.

    The passive port range can be configured in the pure-ftpd configuration file, the same range has to be opened then in the firewall as well.

Share This Page