Perfect server on CentOS 5.0 64 bit

Discussion in 'Installation/Configuration' started by kmullen, Nov 4, 2007.

  1. kmullen

    kmullen New Member

    I'm using the instructions on the Perfect Server CentOS 5.0 (32 bit) on a 64 bit server. I am using the 64bit installation CD's.

    When I get to the part :
    /etc/init.d/httpd start

    after the php installation line and editing the httpd.conf script, it fails returning:

    Invalid command 'index.php3', perhaps misspelled or defined by a module not included in the server configuration

    If I delete that in the DirectoryIndex I get the same error for

    Any help?
  2. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that the DirectoryIndex line is just one line, not multiple ones.
  3. kmullen

    kmullen New Member

    Right again


    Thanks for taking the time to answer all these questions on the forum. You were exactly right. The resolution on my screen did not allow me to put everything on one line.

    Modified and all is fine. Is there a way to type a symbol would tell nano that something is all one line rather than wrapping the text?

    Thanks again.

    Kurt Mullen
  4. tinkerbox

    tinkerbox New Member

    Cant open ISPConfig URL

    rather than start new topic, I thought i can use this to group same problem for CentOS 5 64bit ;)

    I just got the new server from Softlayer, so the OS is still fresh. First step was, configure my box with this tutorial: perfect_setup_centos5.0

    There is no error from step #3(of course SL did the OS install) untill I finished install the ISPConfig. So I tried to open the default URL:, not working :(
    Next i tried open - SSL works
    I also try using the IP, same...

    Then I tried changing the port to 2087(WHM port, and few more free port), this doesnt work as well. tried reboot, check all the service is running and try to open ISPConfig url again, still no luck

    No firewall install on the server, and I have disable firewall on my pc. I have tried this, install centos 5 on my pc and configure it with ISPconfig. It works on my pc.

    I just sent ticket to SL, asking if any problem with the port(although i dont think they block it, just hope if they can advise something..)

    Any idea??
    Im lookin in the darkness...
    Last edited: Nov 11, 2007
  5. tinkerbox

    tinkerbox New Member

    I solved this myself. As i thought no firewall install, actually there is, installed by SL. I thought i removed it :p

    This two lines fixed the problem:
    service apf stop
    service iptables stop

    Someone might asking later, how did i change the port. Stop the ispconfig service:
    /etc/rc.d/init.d/ispconfig_server stop

    Edit this file, search for port 81 or $go_info["server"]["server_url"], change with port number you want
    nano /home/admispconfig/ispconfig/lib/

    Edit this file, change every port 81 you find:
    nano /root/ispconfig/httpd/conf/httpd.conf

    Start ispconfig:
    /etc/rc.d/init.d/ispconfig_server start

Share This Page