Perfect server... ISPConfig trashing dovecot config

Discussion in 'HOWTO-Related Questions' started by krissie, Jun 25, 2010.

  1. krissie

    krissie New Member

    I'm setting up a 32bit server, using the perfect cerver centos5.5 (x86_64) ispconfig3 tutorial, obviously using the i386 packages instead of the x86_64 ones.

    All has gone well, right up untill near the completion of the ISPConfig 3 installation. Basicly, dovecot is failing to start citing an invalid configuration in /etc/dovecot.conf

    When I then enter the command /etc/init.d/dovecot start, I get the following error message in full...

    Starting Dovecot Imap: Error: mail_plugin_dir: Can't acess directory: /usr/lib/dovecot/imap/: Too many levels of symbolic links
    Fatal: Invalid configuration in /etc/dovecot.conf [FAILED]


    I've tried removing ISP config, then removing dovecot, proceeding to reinstall dovecot per the instructions, and starting it with /etc/init.d/dovecot start again..... and it starts. However, when I then run ISPConfig's installer, dovecot once more fails in the same way.

    Can anybody help please?
     
  2. falko

    falko Super Moderator

    Can you post the output of
    Code:
    ls -la /usr/lib/dovecot/imap
    ?
     
  3. krissie

    krissie New Member

    I'm sorry t's taken me so long to respont... and thank you for looking.

    I've since solved the problem. I'm not sure if it's the direct cause, but I updated to a later version of Dovecot with MySQL support, and the issue was resolved.

    Thanks again.
     

Share This Page