Perfect Server install dovecot subfolders

Discussion in 'Installation/Configuration' started by jstrellner, Apr 13, 2008.

  1. jstrellner

    jstrellner New Member


    I followed the tutorial here and got the entire server installed and everything is working great. I have even installed roundcube webmail.

    I have run into two quirks that I can't seem to figure out though.

    1. How do I enable subfolders in IMAP? In outlook I would like to be able to have a subfolder. Right now it can only create them in the same tree as the inbox, drafts, trash, etc. i get, "mail box doesn't allow inferior mail boxes". Never mind, for other people searching, when you create a folder you add a slash at the end to tell it that it is to contain other folders and not mail. e.g. "foldername/" You can then click on that folder and create more subfolders with the slash and keep going deeper, or you can add a folder without the slash and it will create a normal folder that allows you to move mail into that folder.
    2. Any possibility to enable the same login as roundcube? e.g. [email protected]? I found a few threads on the forum, but none seemed to work. Right now it uses, web##_username as the username for SMTP, POP3 and IMAP.

    Thanks for the tutorial guys. I don't think I hit a single snag.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. jstrellner

    jstrellner New Member

    Thanks Till. Unfortunately that post does not seem to fix it.

    I followed Torfinn Nome's post #3 exactly and in the end, I don't think it changed anything. I still need to use web#_username as the IMAP login. I restarted everything and the results are the same. I can log in and everything works as normal with the web#_username.

    I realized that I forgot to add this line when following Torfinn Nome's post:
    auth_username_format ="%Ld_%Ln"
    But once I add that, I can't login under the old or the new format. Any other ideas? Nothing shows up in the /var/log/maillog

    I am testing using outlook, not roundcube.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. jstrellner

    jstrellner New Member

    Thanks again Till,

    You are correct I did miss that. I changed the value in ISPConfig to use that domain value, but now I can't create users. It keeps telling me, "The user name has to contain a minimum of 4 and a maximum of 32 letters or figures and has to begin with a letter" no matter what I put in the username field.

    I restarted ISPConfig just in case it was that. Is there anywhere else that I need to change that value at other than through the form in ISPConfig?
    Never mind, I tried one more thing before I decided to submit this and it worked, for everyones reference you can't use [domain]_ you must use [DOMAIN]_ the case does matter.

    Oh, and you can delete the user without deleting the whole site... but then the user wont be able to add folders and stuff to their email, like actual emails. You get permission issues. So you pretty much need to actually delete everything on the domain.

    In the end I have decided that losing the spam filtering probably isn't worth the username issue. For most people they just enter their pop3/imap username when they are setting up their stuff. Roundcube still takes the normal [email protected] value so I am going to stick with that.

    Thanks for your help with this. Maybe in the future ISPConfig can make it to where this doesn't need to be a hack, but actually the default.

Share This Page