Perfect server insatall problems

Discussion in 'HOWTO-Related Questions' started by ACDII, Sep 21, 2011.

  1. ACDII

    ACDII Member

    Trying to install Fedora 15 x86_64 ISPConfig and hit a roadblock. Most likely due to the version now and when it was written.

    Error: Package: glibc-2.14-5.i686 (updates)
    Requires: glibc-common = 2.14-5
    Installed: glibc-common-2.14-7.x86_64 (@updates-testing)
    glibc-common = 2.14-7
    Available: glibc-common-2.13.90-9.x86_64 (fedora)
    glibc-common = 2.13.90-9
    Available: glibc-common-2.14-5.x86_64 (updates)
    glibc-common = 2.14-5
    You could try using --skip-broken to work around the problem
    ** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
    nss_db-2.2.3-0.5.pre1.fc15.x86_64 has missing requires of
    nss_db-2.2.3-0.5.pre1.fc15.x86_64 has missing requires of

    This is when I am trying to do the rpm build for Courier. I had built a first server already ran into a similar problem and was able to get it working, but dang if I cant remember what I did to do so.
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried
    yum update
    to update all of your packages?

    Which courier-imap version do you try to build?
  3. ACDII

    ACDII Member

    Yep, the update was one of the first steps.

    Here is the Howto I am doing, and the page where I am having the problem.
    I ran into the problems when I ran the second step on this page.
    yum install rpm-build gcc mysql-devel openssl-devel cyrus-sasl-devel pkgconfig zlib-devel pcre-devel openldap-devel postgresql-devel expect libtool-ltdl-devel openldap-servers libtool gdbm-devel pam-devel gamin-devel libidn-devel
  4. ACDII

    ACDII Member

    Here are the packages that are failing


    Everything else installed.

    Interesting, using apt I get this

    apt-get install gcc
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or that some of the repositories
    in use are in an inconsistent state at the moment.

    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    gcc: Depends: libgomp (= 4.6.0-10.fc15)
    E: Broken packages
    Last edited: Sep 22, 2011
  5. ACDII

    ACDII Member

    Well if this dont bugger all. I may have found the problem.

    Found this link regarding gcc.

    It appears the lib files needed are in an updates-testing repo, or got downloaded from one when installing the OS.
    Running yum distro-sync now, and found a lot of the files are either being downgraded, or erased, and a couple match the missing links in the dependency errors.

    Hoping this works.
  6. ACDII

    ACDII Member

    Bingo, running yum distro-sync fixed the problem, everything is working now.

Share This Page